Bug 651993 - Segfault in libaugeas with latest version
Segfault in libaugeas with latest version
Status: CLOSED DUPLICATE of bug 651992
Product: Fedora
Classification: Fedora
Component: augeas (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: David Lutterkort
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2010-11-10 13:38 EST by Brian Ashburn
Modified: 2013-04-30 19:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-11-17 17:16:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Core dump from seg fault (34 bytes, text/plain)
2010-11-10 13:55 EST, Brian Ashburn
no flags Details

  None (edit)
Description Brian Ashburn 2010-11-10 13:38:39 EST
Description of problem:
Running BoxGrinder-build which uses guestfs and augeas, augeas throws a seg fault during aug_save.

Version-Release number of selected component (if applicable):

How reproducible:
Every time I run boxgrinder-build, it occurs.

Steps to Reproduce:
1. Create a basic appliance defintion
2. Run boxgrinder with trace logging
3. Error is in log file
Actual results:
guestfsd[285]: segfault at ff044cc ip 037666d2 sp bf968d40 error 4 in libaugeas.so.0.12.0[3747000+39000]

Expected results:
No segfault

Additional info:
Log file and appliance definitions from boxgrinder: https://gist.github.com/671166
Comment 2 Brian Ashburn 2010-11-10 13:55:47 EST
Created attachment 459520 [details]
Core dump from seg fault
Comment 3 Richard W.M. Jones 2010-11-17 17:16:17 EST

*** This bug has been marked as a duplicate of bug 651992 ***

Note You need to log in before you can comment on or make changes to this bug.