Bug 652 - hard drive install fails
hard drive install fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
i386 Linux
low Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-30 02:08 EST by John Waalkes
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-31 14:49:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Waalkes 1998-12-30 02:08:05 EST
This bug is in the hard drive install procedure.

For systems that are forced to install from a hard drive,
i.e. Linux doesn't recognize the SCSI card, the install
fails when the installer asks for the dos directory and path
where the Redhat files were installed. Redhat reports that
it can't find the files. Just a guess, but it could be
because the installer is trying to mount the partition in
vfat rather than msdos. Who knows?

Workaround:

Follow the instructions provided in the appendix of the
install guide. Create the directories on a dos partition,
copy the files from your CD in dos (or Windows).

Then download the 5.1 installer (boot.img & supp.img) from
the update directory. This works, but fails as it trys to
read the packages from the 5.2 distribution.

Once it tells you that it can't find the packages, select
'menu' and select the next step. I suppose this happens
because the 5.1 installer can't read the 5.2 package table.

You will have to select many more packages than normal as
the pre-picked ones (i.e. the kernel) won't be selected.

Finish the installation as normal.

Have fun! (as they say over at S.u.S.E. :)
Comment 1 Jay Turner 1998-12-30 10:38:59 EST
What utility did you use to copy the files from the CD to the dos
drive?  You will need to xcopy (or xcopy32 if you have it) the files
from the CD or the install will indeed fail as you described.
Comment 2 David Lawrence 1998-12-31 14:49:59 EST
This problem has been observed to be bug with the 5.2 installer. We
have a new boot.img and supp.img for download to help alleviate the
problem.

The new images can be downloaded from

ftp://updates.redhat.com/5.2/images/i386/boot.img
ftp://updates.redhat.com/5.2/images/i386/supp.img

Note You need to log in before you can comment on or make changes to this bug.