Bug 652049 - No output from ipa-getcert list
No output from ipa-getcert list
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: certmonger (Show other bugs)
6.1
All All
low Severity low
: rc
: ---
Assigned To: Nalin Dahyabhai
Jenny Galipeau
:
Depends On:
Blocks: 681642
  Show dependency treegraph
 
Reported: 2010-11-10 16:40 EST by Dmitri Pal
Modified: 2011-05-19 09:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: certmonger-0.34-1.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, the ipa-getcert list command did not return any output if certmonger was not tracking any certificates. With this update, the command returns a message that the certificate list is empty.
Story Points: ---
Clone Of:
: 681642 (view as bug list)
Environment:
Last Closed: 2011-05-19 09:07:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2010-11-10 16:40:53 EST
Description of problem:

If certmonger is not tracking any certs the output of the ipa-getcert list command is empty. I suggest it should be a message or the exit code should have a special meaning. Currently is is a bit unfriendly.
Comment 3 Nalin Dahyabhai 2011-01-11 18:46:05 EST
Fixed in upstream repository, targeting 0.34 release.
Comment 5 Kaleem 2011-03-09 08:17:50 EST
Verified

RHEL version:

[root@localhost ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.1 Beta (Santiago)

Certmonger version:

[root@localhost ~]# rpm -qi certmonger | head
Name        : certmonger                   Relocations: (not relocatable)
Version     : 0.34                              Vendor: Red Hat, Inc.
Release     : 1.el6                         Build Date: Fri 14 Jan 2011 08:30:16 PM IST
Install Date: Wed 09 Mar 2011 05:25:48 PM IST      Build Host: x86-004.build.bos.redhat.com
Group       : System Environment/Daemons    Source RPM: certmonger-0.34-1.el6.src.rpm
Size        : 683642                           License: GPLv3+
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://certmonger.fedorahosted.org
Summary     : Certificate status monitor and PKI enrollment client

Steps used to verify:
(1)install and configure ipa-server with default values(it will also install certmonger since it is a dependency) 
  #yum install ipa-server ipa-client ipa-admintools bind caching-nameserver expect krb5-workstation bind-dyndb-ldap ntpdate krb5-pkinit-openssl
  #ipa-server-install -N --setup-dns (accept all default values and proceed)

(2)started certmonger service
   #service certmonger start

(3)issued a certificate 
   #ipa-getcert request -f /tmp/kaleem/server.crt -k /tmp/kaleem/server.key

(4)stopped tracking of above issued certificate by certmonger
   #ipa-getcert stop-tracking -i request-number

(5)ran command
   #ipa-getcert list
   "Number of certificates and requests being tracked: 0"

Results:
Now ipa-getcert list shows following message instead of empty message when its not tracking any certificate.
"Number of certificates and requests being tracked: 0"
Comment 6 Eva Kopalova 2011-05-02 13:02:57 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, the ipa-getcert list command did not return any output if certmonger was not tracking any certificates. With this update, the command returns a message that the certificate list is empty.
Comment 7 errata-xmlrpc 2011-05-19 09:07:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0570.html

Note You need to log in before you can comment on or make changes to this bug.