Bug 65205 - RFE: pcmcia-cs-source RPM
RFE: pcmcia-cs-source RPM
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-20 05:17 EDT by Ian Pilcher
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 12:07:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SPEC file modified to build pcmcia-cs-source RPM (9.21 KB, text/plain)
2002-05-20 05:21 EDT, Ian Pilcher
no flags Details
SPEC file for linux-wlan-ng drivers; feel free to use it (2.15 KB, text/plain)
2002-05-20 05:25 EDT, Ian Pilcher
no flags Details

  None (edit)
Description Ian Pilcher 2002-05-20 05:17:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510

Description of problem:
I've just gone through the somewhat painful process of creating a Red
Hat-compatible SPEC file for the "linux-wlan-ng" package.  (See
http://www.linux-wlan.org.)  These drivers are a bit of a pain to use,
because they don't support the standard wireless extensions, so they
can't be configured with iwconfig.  However, they do seem to be the
most functional drivers available for 802.11b cards based in Intersil
PRISM chips (which seems to be most of them).

Building the drivers requires access to both a configured kernel 
source tree and a configured pcmcia-cs source tree.  I thought of
building them as a subpackage of kernel-pcmcia-cs, but that doesn't
really make sense, as the package also includes drivers for PCI and
USB adapters.  I also wanted the RPM version to accurately reflect the
driver version.

I finally ended up modifying the kernel-pcmcia-cs SPEC file to build a
pcmcia-cs-source package, with the configured source in /usr/src.  It
strikes me that this might be useful for just about anyone building or
packaging a PCMCIA card driver.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.n/a
2.
3.
	

Additional info:
Comment 1 Ian Pilcher 2002-05-20 05:21:32 EDT
Created attachment 57985 [details]
SPEC file modified to build pcmcia-cs-source RPM
Comment 2 Ian Pilcher 2002-05-20 05:25:09 EDT
Created attachment 57986 [details]
SPEC file for linux-wlan-ng drivers; feel free to use it
Comment 3 Arjan van de Ven 2002-05-20 15:19:13 EDT
The thing is, pcmcia-cs should die; the only thing we use
from it is cardmgr and the config files, none of the kernel
side. If wvlan-ng uses that, it'll not be supported at all...
Comment 4 Scott Porter 2002-10-23 09:18:38 EDT
Well I'd be interested in seeing prism2 continued, the drivers supplied in RH8 
don't work at all with my PCMCIA card, whereas installing a year-old prism2 
driver, and the wlan stuff worked immediately! Unfortunately I can't find any 
source for the driver to work with an smp machine, as no prebuilt RPMs exist, 
and the original author appears to be incommunicado...
Comment 5 Bill Nottingham 2003-02-19 12:07:47 EST
At this point, I don't think we'll do this.

Note You need to log in before you can comment on or make changes to this bug.