Bug 65206 - Focus is not set correctly in Java applications
Focus is not set correctly in Java applications
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-20 05:51 EDT by Thomas M Steenholdt
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-20 10:47:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2002-05-20 05:51:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020516

Description of problem:
When Running a Java application like Robocode, switching windows does not always
set the focus to the new window...

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Install and run robocode (http://robocode.alphaworks.ibm.com)
2.Start the robot editor and create a new robot
3.Choose compile and switch back to the main window
4.Run a new battle and stop it after a few seconds.
5.Quickly switch back to the editor window and see that the cursor does no
appear in the window, making it impossible to edit without reloading the file.
	

Actual Results:  Keyboard focus is still on the robocode window

Expected Results:  Keyboard focus should be on the robot editor window

Additional info:

Tried using icewm instead of sawfish - same result.
Tried using TVM instead of sawfish - unable to reproduce.
Tried using KDE3 instead of Gnome - unable to reproduce.
Comment 1 Havoc Pennington 2002-07-06 22:44:50 EDT
Sawfish is no longer the default window manager in Rawhide, and is provided
optionally on an as-is basis.

Useful detail for debugging this would be your focus mode (mouse, click) and how
you are switching focus - keyboard or mouse.

Suggest reporting this bug to http://bugzilla.gnome.org if it still occurs in
rawhide (Limbo public beta).

Closing on Red Hat level.

Note You need to log in before you can comment on or make changes to this bug.