Bug 65214 - apache in 7.2 & 7.3 uses OPTIONS, but does not source /etc/sysconfig/apache
apache in 7.2 & 7.3 uses OPTIONS, but does not source /etc/sysconfig/apache
Status: CLOSED DUPLICATE of bug 60281
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-20 09:05 EDT by Christian Hechelmann
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-20 09:07:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for init script to source /etc/sysconfig/apache (349 bytes, patch)
2002-05-20 09:07 EDT, Christian Hechelmann
no flags Details | Diff

  None (edit)
Description Christian Hechelmann 2002-05-20 09:05:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; de, de_DE)

Description of problem:
The apache Package in 7.2 and 7.3 uses $OPTIONS in the init script,
but does not source /etc/sysconfig/apache, making it impossible to
add customization and requires editing of the init script after each update.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make a valid /etc/sysconfig/apache with an arbitrary define or
   cmdline option
2. restart apache
3. look at the missing option(s) on the server cmdline

 

Actual Results:  Setting in /etc/sysconfig/apache were completely ignored

Expected Results:  init script should have picked up $OPTIONS form 
/etc/sysconfig/apache

Additional info:

The init script actually uses $OPTIONS (on line 47) but never 
sources /etc/sysconfig/apache
Comment 1 Christian Hechelmann 2002-05-20 09:07:30 EDT
Created attachment 58006 [details]
fix for init script to source /etc/sysconfig/apache
Comment 2 Joe Orton 2002-05-23 12:22:32 EDT

*** This bug has been marked as a duplicate of 60281 ***

Note You need to log in before you can comment on or make changes to this bug.