Bug 652158 - Use of :locked is deprecated
Summary: Use of :locked is deprecated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Net-SNMP
Version: 14
Hardware: Unspecified
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-11 07:56 UTC by Jan ONDREJ
Modified: 2010-12-01 21:54 UTC (History)
5 users (show)

Fixed In Version: perl-Net-SNMP-6.0.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-29 21:38:17 UTC


Attachments (Terms of Use)

Description Jan ONDREJ 2010-11-11 07:56:09 UTC
Description of problem:
Using mrtg on Fedora 14 reports lots of deprecated errors like:

Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 588.

Version-Release number of selected component (if applicable):
mrtg-2.16.4-1.fc14.i686

How reproducible:
alway

Steps to Reproduce:
1. LANG=C mrtg
  
Actual results:
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 588.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 655.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 708.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 764.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 869.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 952.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1028.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1103.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1168.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1325.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1531.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1549.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1563.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1577.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1591.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1613.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1633.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1653.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1674.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1702.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1737.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1846.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1968.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1973.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1978.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 1983.
Usage: mrtg <config-file>
...

Expected results:
Usage: mrtg <config-file>
...

Comment 1 Jan ONDREJ 2010-11-11 08:03:01 UTC
Sorry, looks like wrong component was chosen. Changing component to perl-Net-SNMP.

Comment 2 Fedora Update System 2010-11-17 21:46:58 UTC
perl-Net-SNMP-6.0.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/perl-Net-SNMP-6.0.1-1.fc14

Comment 3 Fedora Update System 2010-11-19 00:04:45 UTC
perl-Net-SNMP-6.0.1-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Net-SNMP'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/perl-Net-SNMP-6.0.1-1.fc14

Comment 4 Harold Campbell 2010-11-19 16:01:45 UTC
The :locked error goes away, but now there is this:


Constant subroutine SNMP_Session::AF_INET6 redefined at /usr/share/perl5/Exporter.pm line 64.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 149
Prototype mismatch: sub SNMP_Session::AF_INET6 () vs none at /usr/share/perl5/Exporter.pm line 64.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 149
Constant subroutine SNMP_Session::PF_INET6 redefined at /usr/share/perl5/Exporter.pm line 64.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 149
Prototype mismatch: sub SNMP_Session::PF_INET6 () vs none at /usr/share/perl5/Exporter.pm line 64.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 149
Constant subroutine SNMPv1_Session::AF_INET6 redefined at /usr/share/perl5/Exporter.pm line 64.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 604
Prototype mismatch: sub SNMPv1_Session::AF_INET6 () vs none at /usr/share/perl5/Exporter.pm line 64.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 604
Constant subroutine SNMPv1_Session::PF_INET6 redefined at /usr/share/perl5/Exporter.pm line 64.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 604
Prototype mismatch: sub SNMPv1_Session::PF_INET6 () vs none at /usr/share/perl5/Exporter.pm line 64.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 604

Comment 5 Jan ONDREJ 2010-11-22 08:40:57 UTC
(In reply to comment #4)
> The :locked error goes away, but now there is this:
> 
> 
> Constant subroutine SNMP_Session::AF_INET6 redefined at
> /usr/share/perl5/Exporter.pm line 64.
>  at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 149
> Prototype mismatch: sub SNMP_Session::AF_INET6 () vs none at
> /usr/share/perl5/Exporter.pm line 64.
>  at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 149

Same problem here. Please, can you make another update?

This is not so easy to reproduce, not enough to run mrtg without parameters, but needs to access SNMP machine.

Comment 6 Tom "spot" Callaway 2010-11-22 14:16:10 UTC
Ugh. I hate it when people drop my patches. :P I need to fix this in mrtg (again). This is 438931 and 442884, back again (because the mrtg maintainer dropped my patch).

I'm going to kick off a build, but I'd like your help in testing this before it goes to an update, as I am not the normal mrtg maintainer.

Comment 7 Tom "spot" Callaway 2010-11-22 14:27:01 UTC
Please download and install this mrtg build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2616001

Then, let me know if it resolves the conflict errors in the logs.

Comment 8 Fedora Update System 2010-11-22 14:38:58 UTC
mrtg-2.16.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mrtg-2.16.4-2.fc14

Comment 9 Vadym Chepkov 2010-11-22 15:08:50 UTC
:(


rpm -qi mrtg
Name        : mrtg                         Relocations: (not relocatable)
Version     : 2.16.4                            Vendor: Fedora Project
Release     : 2.fc14                        Build Date: Mon 22 Nov 2010 09:25:08 AM EST
Install Date: Mon 22 Nov 2010 09:46:31 AM EST      Build Host: x86-02.phx2.fedoraproject.org


Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 588.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 655.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 708.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 764.
Use of :locked is deprecated at /usr/share/perl5/Net/SNMP.pm line 869.

Comment 10 Vadym Chepkov 2010-11-22 15:11:40 UTC
My bad, didn't update perl-Net-SNMP
Seems to be working now, thanks

Comment 11 Harold Campbell 2010-11-22 16:32:21 UTC
Updated mrtg looks good here.

Comment 12 Fedora Update System 2010-11-29 21:38:13 UTC
perl-Net-SNMP-6.0.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-12-01 21:54:48 UTC
mrtg-2.16.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.