Bug 652194 - [abrt] Zim-0.48-1.fc14: __init__.py:227:__init__:AttributeError: 'NoneType' object has no attribute 'get_status'
[abrt] Zim-0.48-1.fc14: __init__.py:227:__init__:AttributeError: 'NoneType' o...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
14
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
abrt_hash:a01a78fb
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-11 05:44 EST by Luca Botti
Modified: 2010-11-12 10:59 EST (History)
3 users (show)

See Also:
Fixed In Version: Zim-0.49-1.fc14.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-12 10:59:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (960 bytes, text/plain)
2010-11-11 05:45 EST, Luca Botti
no flags Details

  None (edit)
Description Luca Botti 2010-11-11 05:44:58 EST
abrt version: 1.1.13
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/zim
component: Zim
executable: /usr/bin/zim
kernel: 2.6.35.6-48.fc14.x86_64
package: Zim-0.48-1.fc14
reason: __init__.py:227:__init__:AttributeError: 'NoneType' object has no attribute 'get_status'
release: Fedora release 14 (Laughlin)
time: 1289472316
uid: 500

backtrace
-----
__init__.py:227:__init__:AttributeError: 'NoneType' object has no attribute 'get_status'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/zim/plugins/versioncontrol/__init__.py", line 176, in save_version
    SaveVersionDialog(self.ui, self.vcs).run()
  File "/usr/lib/python2.7/site-packages/zim/plugins/versioncontrol/__init__.py", line 227, in __init__
    status = self.vcs.get_status()
AttributeError: 'NoneType' object has no attribute 'get_status'

Local variables in innermost frame:
self: <SaveVersionDialog object at 0x18f5af0 (zim+gui+widgets+Dialog at 0x1acc050)>
vpaned: <gtk.VPaned object at 0x18f5be0 (GtkVPaned at 0x197da40)>
label: <gtk.Label object at 0x18f5c80 (GtkLabel at 0x1ac0b80)>
vbox: <gtk.VBox object at 0x18f5c30 (GtkVBox at 0x1975e60)>
window: <gtk.ScrolledWindow object at 0x18f5b40 (GtkScrolledWindow at 0x1ac12c0)>
vcs: None
ui: <GtkInterface object at 0x1282e10 (zim+gui+GtkInterface at 0x179c700)>

How to reproduce
-----
1. Open Zim
2. Select File/Save Version
3. Zim asks to enable version control 
4. Select no
5. Zim crashes
Comment 1 Luca Botti 2010-11-11 05:45:00 EST
Created attachment 459717 [details]
File: backtrace
Comment 2 Robin Lee 2010-11-11 09:20:13 EST
I can't reproduce this bug with Zim 0.49, which will be soon available in F14 updates.

Or download from here: http://kojipkgs.fedoraproject.org/packages/Zim/0.49/1.fc14/noarch/Zim-0.49-1.fc14.noarch.rpm

Try it and feedback.

Note You need to log in before you can comment on or make changes to this bug.