Bug 652216 - Review Request: rubygem-i18n - New wave Internationalization support for Ruby
Summary: Review Request: rubygem-i18n - New wave Internationalization support for Ruby
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-11 11:59 UTC by Jozef Zigmund
Modified: 2015-02-17 13:46 UTC (History)
4 users (show)

Fixed In Version: rubygem-i18n-0.4.2-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-08 21:40:38 UTC
mtasaka: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Jozef Zigmund 2010-11-11 11:59:23 UTC
Spec URL: http://people.redhat.com/jzigmund/rubygem-i18n.spec
SRPM URL: http://people.redhat.com/jzigmund/rubygem-i18n-0.4.2-1.fc13.src.rpm
Description: Ruby Internationalization and localization solution.

Comment 1 Mamoru TASAKA 2010-11-11 19:09:43 UTC
For -1:

* Licensing
---------------------------------------------------
Overall:	MIT

Ruby or GPLv2:
./lib/i18n/core_ext/string/interpolate.rb
./lib/i18n/gettext/po_parser.rb
---------------------------------------------------
  - The license tag for this should be "MIT and (GPLv2 or Ruby)".

* rpmlint issue
---------------------------------------------------
rubygem-i18n.noarch: E: script-without-shebang /usr/lib/ruby/gems/1.8/gems/i18n-0.4.2/MIT-LICENSE
rubygem-i18n.noarch: E: script-without-shebang /usr/lib/ruby/gems/1.8/gems/i18n-0.4.2/lib/i18n.rb
---------------------------------------------------
  - These files should have 0644 permission (i.e. should not have
    executable permission)

Comment 2 Jozef Zigmund 2010-11-18 13:24:13 UTC
(In reply to comment #1)
> For -1:
> 
> * Licensing
> ---------------------------------------------------
> Overall: MIT
> 
> Ruby or GPLv2:
> ./lib/i18n/core_ext/string/interpolate.rb
> ./lib/i18n/gettext/po_parser.rb
> ---------------------------------------------------
>   - The license tag for this should be "MIT and (GPLv2 or Ruby)".
> 

[Fixed]

> * rpmlint issue
> ---------------------------------------------------
> rubygem-i18n.noarch: E: script-without-shebang
> /usr/lib/ruby/gems/1.8/gems/i18n-0.4.2/MIT-LICENSE
> rubygem-i18n.noarch: E: script-without-shebang
> /usr/lib/ruby/gems/1.8/gems/i18n-0.4.2/lib/i18n.rb
> ---------------------------------------------------
>   - These files should have 0644 permission (i.e. should not have
>     executable permission)

[Fixed]

New SPEC URL: http://people.redhat.com/jzigmund/rubygem-i18n.spec
NEw SRPM URL: http://people.redhat.com/jzigmund/rubygem-i18n-0.4.2-2.fc13.src.rpm

Comment 3 Mamoru TASAKA 2010-11-18 18:56:52 UTC
Approving

---------------------------------------------------------
  This package (rubygem-i18n) is APPROVED by mtasaka
---------------------------------------------------------

Comment 4 Jozef Zigmund 2010-11-19 12:52:14 UTC
New Package SCM Request
=======================
Package Name:      rubygem-i18n
Short Description: New wave Internationalization support for Ruby
Owners:            jzigmund
Branches:          f13 f14

Comment 5 Jason Tibbitts 2010-11-22 13:56:43 UTC
Git done (by process-git-requests).

Comment 6 Fedora Update System 2010-11-22 15:44:41 UTC
rubygem-i18n-0.4.2-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/rubygem-i18n-0.4.2-2.fc13

Comment 7 Fedora Update System 2010-11-22 15:45:35 UTC
rubygem-i18n-0.4.2-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rubygem-i18n-0.4.2-2.fc14

Comment 8 Fedora Update System 2010-11-22 22:18:26 UTC
rubygem-i18n-0.4.2-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rubygem-i18n'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/rubygem-i18n-0.4.2-2.fc14

Comment 9 Fedora Update System 2010-12-08 21:40:33 UTC
rubygem-i18n-0.4.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-12-08 21:41:30 UTC
rubygem-i18n-0.4.2-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Vít Ondruch 2011-03-15 09:23:46 UTC
Package Change Request
======================
Package Name: rubygem-i18n
New Branches: el5 el6
Owners: vondruch stahnma


Also please could you unretire f14 branch which was accidentally retired by previous maintainer.

Comment 12 Jason Tibbitts 2011-03-15 15:10:47 UTC
Git done (by process-git-requests).

Comment 13 Jason Tibbitts 2011-03-15 15:23:38 UTC
I believe the f14 branch is fixed up as well; please let me know if you need anything else.

Comment 14 Vít Ondruch 2011-03-16 09:48:52 UTC
f14 seems to be ok. Thank you very much.

Comment 15 Josef Stribny 2015-02-17 12:55:41 UTC
Package Change Request
======================
Package Name: rubygem-i18n
New Branches: epel7
Owners: jstribny humaton

Comment 16 Gwyn Ciesla 2015-02-17 13:46:07 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.