Bug 65225 - gssapi authentication just won't work in cvs 1.11.2
gssapi authentication just won't work in cvs 1.11.2
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: cvs (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-20 13:01 EDT by Jonathan Kamens
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-20 13:02:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
don't use stdio buffer closure incorrectly (1.46 KB, patch)
2002-05-20 13:02 EDT, Jonathan Kamens
no flags Details | Diff

  None (edit)
Description Jonathan Kamens 2002-05-20 13:01:45 EDT
(I reported this bug to bug-cvs@gnu.org as well.)

"gserver" authentication won't work in cvs-1.11.2, because it attempts
to use the closure of a stdio buffer incorrectly.  Any attempt to use
gserver authentication yields the error message "gserver currently
only enabled for socket connections."

I've attached a diff which fixes this problem and abstracts access to
this information to make it less likely that the problem will occur in
the future.
Comment 1 Jonathan Kamens 2002-05-20 13:02:16 EDT
Created attachment 58016 [details]
don't use stdio buffer closure incorrectly
Comment 2 Nalin Dahyabhai 2002-06-04 17:57:24 EDT
Incorporating into 1.11.2-3.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.