Bug 65229 - Hard drive ISO install incomplete on mixed IDE/scsi system
Hard drive ISO install incomplete on mixed IDE/scsi system
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-20 14:03 EDT by Jack Bowling
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 17:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Bowling 2002-05-20 14:03:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Hard drive install incomplete on mixed IDE/scsi disk array.

During a hard drive ISO install, scsi drivers are not loaded before Disk Druid
is instantiated therefore rendering any scsi disks invisible. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Select install from Hard Drive
2.Give ISO location to installer
3.Disk Druid pops up but scsi drives invisible
	

Actual Results:  Disk Druid does not show scsi drives so selecting any paritions
on scsi drives impossible.

Expected Results:  scsi drivers should have loaded before Disk Druid.

Additional info:

should be an easy fix since the CD install Does The Right Thing.
Comment 1 Michael Fulbright 2002-05-20 14:46:34 EDT
What SCSI hardware is on your system?
Comment 2 Jack Bowling 2002-05-20 17:00:35 EDT
Sorry. I forgot this part. I have two scsi controllers: and initio-based IWill
adapter, and an NCR53c810. Here is my /etc/modules.conf after the successful
install:

alias parport_lowlevel parport_pc
alias scsi_hostadapter sym53c8xx
alias eth0 8139too
alias scsi_hostadapter1 initio
alias sb emu10k1
options scanner vendor=0x04b8 product=0x0112

My /var partition is on the NCR adapter.

jack
Comment 3 Michael Fulbright 2002-06-12 12:43:59 EDT
Thanks will assign to an engineer.
Comment 4 Jeremy Katz 2002-06-21 16:48:45 EDT
If you run lsmod on tty2, which SCSI driver are you not seeing loaded?  Also,
what are the contents of /tmp/modules.conf during the install?
Comment 5 Jack Bowling 2002-06-29 05:26:51 EDT
Hi, Jeremy. Sorry for the long delay getting back to you. I think I have figured
out how to do a hard drive install properly with my system. When I select the
Hard Drive install and get to the screen to choose the directory with the ISOs,
instead I have to first hit F2 twice to get to the screen to load the driver
disk. Once I have the initio driver loaded, then all the partitions can be seen.
Unfortunately for some unknown reason when I tried it this time, the installer
is bombing, though: when I feed it the directory with the ISOs, it just keeps
coming back saying that there are no RH ISOs in the directory. I downloaded them
fresh today and the md5sums check out so I have no clue what this is about. But
that would be another bug :-)) As for bug 65229, I think we can close this one.
However, it might be an idea to highlight the fact that a user with a scsi
adapter that is not one of the three on the install floppy is going to have to
use a driver disk before choosing the ISO directory to allow Anaconda/Disk Druid
to see all their partitions.

Oh, BTW, there is no way to get to a console on tty2 since that function has
been deactivated in RH 7.3 Anaconda :-(( 

thanks for your time,
Jack Bowling
jbinpg@shaw.ca
Comment 6 Jeremy Katz 2002-08-13 00:33:00 EDT
You can get to tty2, just not until the second stage has loaded.

As to needing a driver disk, you always need a driver disk if it's not one of
the "major" drivers that is supported for installation.
Comment 7 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.