Bug 652296 - Current updateinfo data is broken (epoch="None")
Current updateinfo data is broken (epoch="None")
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: bodhi (Show other bugs)
el5
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-11 10:22 EST by James Antill
Modified: 2016-09-19 22:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 16:08:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2010-11-11 10:22:52 EST
Description of problem:
 The yum in RHEL-5 (not 100% sure about RHEL-6) just takes the epoch values as given, so:

        <package arch="x86_64" epoch="None" name="sslscan" release="3.el5" src="
http://download.fedoraproject.org/pub/fedora/linux/updates/5/x86_64/sslscan-1.8.
2-3.el5.x86_64.rpm" version="1.8.2">

...only matches to packages which have epoch="None" (or higher).

Version-Release number of selected component (if applicable):
 Current repodata.
Comment 1 Luke Macken 2011-06-13 10:06:06 EDT
This issue should be resolved with the latest version of bodhi in production (v0.8.0).
Comment 2 Luke Macken 2011-06-13 10:09:04 EDT
Actually, I still see epoch="None" in the current updateinfo, which could be due to old cached metadata.  I just cleaned it out, so I'm going to re-open this ticket until I can confirm that they are gone.
Comment 3 Luke Macken 2011-10-24 16:08:18 EDT
This issue has been resolved.

Note You need to log in before you can comment on or make changes to this bug.