Bug 6523 - problems communicating to external modem
problems communicating to external modem
Product: Red Hat Linux
Classification: Retired
Component: setserial (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 1999-10-30 00:38 EDT by rhopkins
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-11-25 23:12:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description rhopkins 1999-10-30 00:38:28 EDT
I've been running RH 5.0, 5.1, 5.2, and 6.0, and i have
never had any problems with it and my Zoom 56K data/fax
external modem.  Instead of simply upgrading to 6.1 on my
box, i wiped my drives and installed it fresh, and now i
can't get my modem to work at all.  After checking around
some, I noticed that there wasn't a rc.serial file in
the /etc/rc.d directory.  I simply copied the the file from
the setserial doumentation files, set it up according to
the docs, and still nothing.  What else can i do?  I
haven't tried to recompile a kernel yet though, I don't
want to do that except as a last resort.  Maybe something
fishy in the stock kernel??  i did notice on boot that it
reports the serial devices as /dev/ttyS00 and /dev/ttyS01,
instead of ttyS0 ans ttyS1.  i'm not a kernel whiz though.
contact me if ya need more info.
Comment 1 rhopkins 1999-11-25 23:12:59 EST
Ok i got my modem to work, it was one of those slap the forehead and go duh!
mistakes.  For some reason, i had my modem connected to my /dev/ttys1 (com 2)
port, so i set /dev/modem to that and i can actually do something with my modem
now.  Wierd thing is though is that I had set /dev/modem to ttys0 in RH60 and
it worked there. I have come across another problem though.  When i try to dial
out using ppp, it hangs right when wvdial or chat scripts send the ATDT line to
the modem.  Now i know the modem works because i can properly dial out with it
to my ISP using mimicom.  Should i file another bug report on this?
Comment 2 David Lawrence 2000-08-08 11:35:58 EDT
Please file another report for his problem against wvdial if this problem still
persists in 6.2.

Note You need to log in before you can comment on or make changes to this bug.