This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 652489 - Fedora 14 Can't use >1 CPU as a KVM VM
Fedora 14 Can't use >1 CPU as a KVM VM
Status: CLOSED DUPLICATE of bug 644973
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
14
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-11 20:51 EST by digimer
Modified: 2010-11-12 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-12 17:10:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
XML from 'virsh dumpxml' after a successful install on 1 CPU was modified to use 3 CPUs. (1.90 KB, text/xml)
2010-11-11 20:51 EST, digimer
no flags Details
Screenshot of hang. Note the CPU usage in virt-manager (kvm-an-node07 -> vm_01) (306.59 KB, image/png)
2010-11-11 20:53 EST, digimer
no flags Details

  None (edit)
Description digimer 2010-11-11 20:51:32 EST
Created attachment 459892 [details]
XML from 'virsh dumpxml' after a successful install on 1 CPU was modified to use 3 CPUs.

Description of problem:

Unable to run Fedora 14 x86_64 as a KVM VM with more than 1 CPU. Works fine as a Xen VM. It manifests as a hang very early in the boot process (see attached screen shot)

Version-Release number of selected component (if applicable):

Fedora 14 x86_64 up to date as of Nov. 10, host and VM.
qemu-system-x86-0.13.0-1.fc14.x86_64
qemu-kvm-0.13.0-1.fc14.x86_64
qemu-kvm-tools-0.13.0-1.fc14.x86_64
libvirt-0.8.3-2.fc14.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Provision a VM with >1 CPU. Alternatively, use virsh to redefine an existing VM to have more that 1 CPU.
2. Start the VM and connect over VNC.
3. Hang occurs very shortly after boot.
  
Actual results:

VM hangs

Expected results:

VM boots

Additional info:

Hang happened while trying to provision using virt-manager GUI, virt-install and by modifying an existing VM to use >1 CPU.

See attached 'virsh dumpxml' file and attached screen shot of the hang.
Comment 1 digimer 2010-11-11 20:53:16 EST
Created attachment 459893 [details]
Screenshot of hang. Note the CPU usage in virt-manager (kvm-an-node07 -> vm_01)
Comment 2 digimer 2010-11-11 21:02:26 EST
I tried to simplify things with the following provision but it still hangs at the same place. If I remove '--vcpus 3' it works.

virt-install --connect qemu:///system --virt-type kvm --name hang_test --ram 3072 --arch x86_64 --location http://192.168.1.254/f14/x86_64/img/ --os-type linux --os-variant fedora14 --nodisk --vnc --vcpus 3
Comment 3 digimer 2010-11-11 21:11:39 EST
This seems to be OS specific. I tested a basic install using RHEL6 just now and it did not hang. Provision string was:

virt-install --connect qemu:///system --virt-type kvm --name hang_test --ram 3072 --arch x86_64 --location http://192.168.1.254/rhel6/x86_64/img/ --os-type linux --os-variant rhel6 --nodisk --vnc --vcpus 3
Comment 4 Paul Jenner 2010-11-12 17:01:22 EST
There appear to be a few similar bug reports. Is this a duplicate of bug #652373 or (possibly better) bug #644973?
Comment 5 digimer 2010-11-12 17:10:38 EST
bug #652373 sounds similar, but it sounds like that person is getting much further in than I am (I never see a countdown). This does seem to be a duplicate of bug #644973 though. I will close this as it's duplicate.

*** This bug has been marked as a duplicate of bug 644973 ***

Note You need to log in before you can comment on or make changes to this bug.