Bug 652524 - [abrt] rakarrack-0.5.8-2.fc14: Process /usr/bin/rakarrack was killed by signal 6 (SIGABRT)
[abrt] rakarrack-0.5.8-2.fc14: Process /usr/bin/rakarrack was killed by signa...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rakarrack (Show other bugs)
14
i686 Unspecified
low Severity medium
: ---
: ---
Assigned To: David Timms
Fedora Extras Quality Assurance
abrt_hash:3b8d0aef2d633fe05f7373b56bd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-12 01:05 EST by savailonei
Modified: 2011-02-07 15:02 EST (History)
1 user (show)

See Also:
Fixed In Version: rakarrack-0.6.1-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-13 06:57:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (5.87 KB, text/plain)
2010-11-12 01:05 EST, savailonei
no flags Details
rakarrack death when jack server "stop"ed (4.33 KB, text/plain)
2010-11-13 09:45 EST, David Timms
no flags Details

  None (edit)
Description savailonei 2010-11-12 01:05:49 EST
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: rakarrack
component: rakarrack
executable: /usr/bin/rakarrack
kernel: 2.6.35.6-48.fc14.i686
package: rakarrack-0.5.8-2.fc14
rating: 4
reason: Process /usr/bin/rakarrack was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1289541689
uid: 500

How to reproduce
-----
1. start jack server
2. start rakarrack
3. stop jack server
Comment 1 savailonei 2010-11-12 01:05:52 EST
Created attachment 459924 [details]
File: backtrace
Comment 2 David Timms 2010-11-13 09:45:10 EST
Created attachment 460241 [details]
rakarrack death when jack server "stop"ed

(In reply to comment #0)
> How to reproduce
> -----
> 1. start jack server
> 2. start rakarrack
> 3. stop jack server
When you did this, did you see the dialog, "Warning - Jack Audio Connection Kit:
Some client audio applications are still active and connected.

Do you want to stop the JACK audio server ?"

Did you hit Yes to this dialog ?

When I did I got a different backtrace.
Comment 3 savailonei 2010-11-15 02:18:27 EST
I did see the dialog. And yes I hit 'Yes'. I checked it again just now, to be sure, but the backtrace remains the same as the one I've already posted.
Comment 4 savailonei 2010-11-15 02:39:02 EST
I think the differences in backtraces may be caused by different timing - rakarrack was interrupted in different moments. By the way, the version of my rakarrack is 0.5.8-2 and it runs on latest Fedora 14, maybe your setup differs a little bit?
Comment 5 David Timms 2010-12-13 06:57:16 EST
I've updated rakarrack locally to 0.6.1, which continues to close in the above way when the jack server is stopped. I have made a feature request of the upstream developers, in the hope that there is a nicer way to exit rakarrack should the jack server exit. If you know of other jack clients that do this nicely, we mght be able to hunt down some existing shutdown/exception handling code.

Ref: https://sourceforge.net/tracker/?group_id=215888&atid=1035485

Closing this as upstream, and hoping for a future upstream resolution.
Comment 6 Fedora Update System 2010-12-15 07:29:56 EST
rakarrack-0.6.1-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/rakarrack-0.6.1-2.fc13
Comment 7 Fedora Update System 2010-12-15 07:48:21 EST
rakarrack-0.6.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rakarrack-0.6.1-2.fc14
Comment 8 Fedora Update System 2011-01-09 15:59:52 EST
rakarrack-0.6.1-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2011-02-07 15:02:25 EST
rakarrack-0.6.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.