Bug 65261 - XFree86-3 is installed instead of XFree86-4
XFree86-3 is installed instead of XFree86-4
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-21 00:05 EDT by Dmitry Bolkhovityanov
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-21 00:51:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Bolkhovityanov 2002-05-21 00:05:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
When installing on a machine with Matrox Millenium videocard, Anaconda makes
XFree86-3 the default instead of XFree86-4.  Millenium *is* supported by XFree86-4.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHL on a machine with Matrox Millenium.
2. Do "ls -l /etc/X11/X"

	

Actual Results:  lrwxrwxrwx 1 root root 27 May 11 04:09 /etc/X11/X ->
../../usr/X11R6/bin/XF86_SVGA

Expected Results:  lrwxrwxrwx 1 root root 27 May 11 04:09 /etc/X11/X ->
../../usr/X11R6/bin/XFree86

Additional info:

As I understand, Anaconda should behave as follows: 

if (<the card is supported by XFree86-4>)
    <Install XFree86-4 as default>
else
    <Install XFree86-3 as default>

But either Millenium is listed as unsupported by -4, or the real behaviour is
reverse, i.e.

if (<the card is supported by XFree86-3>)
    <Install XFree86-3 as default>
else
    <Install XFree86-4 as default>

This bug existed at least since 7.1.

BTW, as far as I know, XFree86-4 supports *all* Matrox cards which were
supported by XFree86-3, so that there's no reason to install 3-rd version on
*any* of Matrox cards. (In fact, "mga" driver was one of the first ported from
-3 to -4).
Comment 1 Mike A. Harris 2002-05-21 00:51:44 EDT
Reassigning to myself, and changing component to Xconfigurator, since
the Cards database is what decides this, not anaconda.
Comment 2 Mike A. Harris 2002-05-21 01:00:26 EDT
The reason that XFree86 3.3.6 is the default for *any* card still, depends
on one of several factors.

1) The card is totally unsupported by XFree86 4.x

or

2) The 4.x support is totally broken for the card, even though 4.x claims to
   support it.

or

3) The 4.x support has some problems, and 3.3.6 has been tested either
   internally, or by end users to work better than the 4.x version.

In either of the above 3 scenarios, the default gets set to the 3.3.6
Server that supports the hardware best.  In the case of the Matrox Millenium,
the default is set to 3.3.6 due to bug reports in the 4.x drivers.  Our
interest, is in having the default video driver *WORK*, and provide the
user with the most stable desktop.  As such, this default is very much
100% intentional, and this is not a bug.

You are welcome to run Xconfigurator --preferxf4 if you prefer the
XFree86 4.x driver, and it works for you.  As long as we ship XFree86
4.x and 3.3.6 together, the Millenium driver will default to 3.3.6
unless I spot changlog entries indicating the bugs have been fixed.

That said, it is very likely that 3.3.6 will be dropped from the
distribution in the not to distant future, and all hardware will then
either use 4.x, or be completely unsupported if 4.x doesn't function.

Note You need to log in before you can comment on or make changes to this bug.