Bug 65262 - gdm session file versus Xsession
gdm session file versus Xsession
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-21 00:07 EDT by jeramy smith
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-21 00:07:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jeramy smith 2002-05-21 00:07:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.0rc2) Gecko/20020513

Description of problem:
Simple, the gdm windowmaker session file executes Xsession wmaker instead of
executing window maker directly. The problem is there is now corresponding
Xclients.wmaker but instead Xclients.windowmaker

You can either:
1. have the gdm session file execute the window maker binary instead of Xsession
2. change Xsession wmaker to Xsession windowmaker 
3. mv Xclients.windowmaker Xclients.wmaker

The effect of this bug is that the window maker entry in gdm does not work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install window maker
2.log out of X
3.choose window maker
4.log in to X

	

Actual Results:  gnome was executed

Expected Results:  window maker should have run

Additional info:

This is a bad bug since the login is one where people form their first
impressions of red hat. If the login cant even get the right desktop, that says
something to Joe Newbie. I won't make this a severe bug though.
Comment 1 Phil Copeland 2002-08-07 22:01:21 EDT
Fixed in rawhide (using 3rd option)

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.