Bug 652626 - org.hibernate.MappingException: Named query not known: KickstartableTree.findByCobblerIdorXenId
org.hibernate.MappingException: Named query not known: KickstartableTree.find...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
540
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Miroslav Suchý
Jan Hutař
:
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-11-12 06:17 EST by Miroslav Suchý
Modified: 2011-03-17 10:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 10:12:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2010-11-12 06:17:11 EST
Description of problem:
I find in log this error message:
org.hibernate.MappingException: Named query not known: KickstartableTree.findByCobblerIdorXenId
I dunno how it was coused (I recently synced RHEL and created 4 new Ks).

Version-Release number of selected component (if applicable):
sat540

How reproducible:
happen to me

Steps to Reproduce:
1. ??
  
Actual results:
INFO   | jvm 3    | 2010/11/12 12:01:43 | com.redhat.rhn.common.hibernate.HibernateRuntimeException: Mapping not found for KickstartableTree.findByCobblerIdorXenId
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at com.redhat.rhn.common.hibernate.HibernateFactory.lookupObjectByNamedQuery(HibernateFactory.java:185)
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at com.redhat.rhn.common.hibernate.HibernateFactory.lookupObjectByNamedQuery(HibernateFactory.java:158)
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at com.redhat.rhn.domain.kickstart.KickstartFactory.lookupKickstartTreeByCobblerIdOrXenId(KickstartFactory.java:186)
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at com.redhat.rhn.manager.kickstart.cobbler.CobblerProfileSyncCommand.syncProfileToSpacewalk(CobblerProfileSyncCommand.java:139)
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at com.redhat.rhn.manager.kickstart.cobbler.CobblerProfileSyncCommand.store(CobblerProfileSyncCommand.java:107)
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at com.redhat.rhn.taskomatic.task.CobblerSyncTask.execute(CobblerSyncTask.java:102)
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at com.redhat.rhn.taskomatic.task.RhnJavaJob.execute(RhnJavaJob.java:80)
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at com.redhat.rhn.taskomatic.TaskoJob.execute(TaskoJob.java:168)
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at org.quartz.core.JobRunShell.run(JobRunShell.java:214)
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:549)
INFO   | jvm 3    | 2010/11/12 12:01:43 | Caused by:
INFO   | jvm 3    | 2010/11/12 12:01:43 | org.hibernate.MappingException: Named query not known: KickstartableTree.findByCobblerIdorXenId
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at org.hibernate.impl.AbstractSessionImpl.getNamedQuery(AbstractSessionImpl.java:70)
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at org.hibernate.impl.SessionImpl.getNamedQuery(SessionImpl.java:1260)
INFO   | jvm 3    | 2010/11/12 12:01:43 |       at com.redhat.rhn.common.hibernate.HibernateFactory.lookupObjectByNamedQuery(HibernateFactory.java:179)
INFO   | jvm 3    | 2010/11/12 12:01:43 |       ... 9 more
Comment 1 Miroslav Suchý 2010-11-12 06:23:22 EST
That is caused by typo in named sql query.
Fixed in spacewalk.git f3de94301264ab54fce401d4422faaafa1c9b617
Comment 3 Marcus Moeller 2010-12-13 09:26:15 EST
Is there an errata scheduled for that?
Comment 4 Clifford Perry 2010-12-13 09:35:28 EST
yes, likely in next 1 -> 4 months.
Comment 5 Sandro Mathys 2010-12-13 12:38:24 EST
Reproduced and fix verified.
Comment 12 Jan Hutař 2011-02-28 07:20:11 EST
Hello,
does anybody have some info on how to trigger this issue?

Thanks,
Jan
Comment 17 errata-xmlrpc 2011-03-17 10:12:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0362.html

Note You need to log in before you can comment on or make changes to this bug.