Bug 65264 - iwconfig WEP key configuration fails 7.2 worked fine. Using airo
iwconfig WEP key configuration fails 7.2 worked fine. Using airo
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-21 02:07 EDT by Dax Kelson
Modified: 2007-04-18 12:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-31 12:16:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2002-05-21 02:07:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
I have a Cisco Aironet 350 PCMCIA card. With RHL 7.2 everything worked great
with configuring WEP keys and the like.  With RHL 7.3 I get error messages and
it doesn't configure WEP. The iwconfig program also complains about mismatched
Wireless Extension versions.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Run 'iwconfig ethX" notice the complaint
2.Run 'iwconfig ethX key s:testing restricted' notice the nasty error
3.Try with Red Hat Linux 7.2 and notice that it works

Actual Results:  n/a

Expected Results:  n/a

Additional info:

I tried with the stock 7.3 kernel, and the  2.4.18-4 errata kernel with the same
results. This worked fine with RHL 7.2

# iwconfig eth1
Warning : Device eth1 has been compiled with version 1
of Wireless Extension, while we are using version 12.
Some things may be broken...

eth1      IEEE 802.11-DS  ESSID:"TESTING"  Nickname:"mentor"
          Mode:Managed  Frequency:2.412GHz  Access Point: FF:FF:FF:FF:FF:FF
          Bit Rate:11Mb/s   Tx-Power=20 dBm   Sensitivity=0/-1056964560
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:176  Signal level:0  Noise level:0
          Rx invalid nwid:4304  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:46862   Missed beacon:0

Try setting a key:

# iwconfig eth1 key s:testing restricted
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device eth1 ; Operation not supported.

I also tried compiling the "24" wireless tools and got the same error when
setting the key.

Info about the card:
airo:  Probing for PCI adapters
airo:  Finished probing for PCI adapters
airo: Doing fast bap_reads
airo: MAC enabled eth1 0:40:96:41:b2:ef
eth1: index 0x05: Vcc 5.0, Vpp 5.0, irq 3, io 0x0100-0x013f

Again, this worked fine with RHL 7.2.

This is my interface config file that USED to work with RHL 7.2.

# cat ifcfg-eth1
DEVICE=eth1
BOOTPROTO=dhcp
ONBOOT=no
USERCTL=yes
ESSID=TESTING
KEY="4b0fa2e76cfba2ad1fe6528383 restricted"
# No, this is not my real key or ESSID
Comment 1 James Manning 2002-05-22 15:38:15 EDT
i'm seeing the same thing and I can narrow down the parameters significantly.

7.2 machine, all errata applied, wireless-tools-21-3

setting WEP keys attempted with:

iwconfig eth0 key 1234-5678-90 [1] key 1234-5678-90 [2] key 1234-5678-90 [3] key
1234-5678-90 [4]

(the actual hex values are different, but the above is the used form)

If booted to 2.4.7-10 (7.2 default kernel), the above iwconfig form works fine,
the connection works like a charm.

Same machine, just rebooted over to 2.4.9-31 errata kernel gives:

SIOCSIWENCODE(95): Operation not supported

all other forms of key-setting attempts seem to result in the same, including
"iwconfig eth0 key s:foo".

iwconfig eth0 spits the usual warning about compiled with 64, using version 11

since wireless-tools is the same in both cases, changing bug to kernel and
version back to 7.2 in the hopes it'll help track down the offender
Comment 2 James Manning 2002-05-22 15:39:16 EDT
might as well reassign to arjan, too
Comment 3 James Manning 2002-05-22 17:48:02 EDT
sorry for the mass-changes, but upon realization that anything tagged against
RHL  7.2 might get ignored, i'll send this back to 7.3 since it's indeed still
broken there - i'm installing the 2.4.9-{7,13,21} kernels now to narrow down the
scope
Comment 4 James Manning 2002-05-22 18:03:40 EDT
already broke with 2.4.9-7 - arjan, can you recommend and point to any
intermediary kernels between that and 2.4.7-10 that i could try to narrow it
down?  I may only have this test laptop another day, but I'd like to nail this soon.
Comment 5 Arjan van de Ven 2002-05-28 07:36:15 EDT
One of the things to try would be to move away one of the 2 (!!)
airo.o/airo_cs.o module pairs that got included accidentally. One of them is old
and should be removed; but was shipped by accident.
Comment 6 Dax Kelson 2002-05-28 15:03:03 EDT
Now WEP and everything works after doing: 

# cd /lib/modules/VER/
# rm ./kernel/drivers/net/pcmcia/airo* ./pcmcia/airo*
# depmod -a

That leaves only the correct drivers in the directory:

./kernel/drivers/net/wireless/

Now everything is working normally again.
Comment 7 James Manning 2002-05-31 12:16:02 EDT
confirmed, works like a champ here

any chance for an upcoming round of kernel errata to include this fix?  hey, I
can dream :)
Comment 8 Arjan van de Ven 2002-06-20 09:44:56 EDT
2.4.18-5 has this fixed
Comment 9 spyro malaspinas 2002-10-14 18:25:05 EDT
I am having similar problems with the RedHat 8 distr. Everything is working ok, 
except for my wireless aironet 350.  When attempting to activate through the 
>redhat-config-network.  I get an error after attempting to activate the cisco 
aironet wireless pcmcia card.
 
The error message that I am getting Warning : Device eth1 has been compiled 
with version 13 of wireless extension while we are using version 12

The odd thing is that I am able to ping the router once the card has been 
activated for the first time, then upon reboot, I am unable to activate card 
again. As the card shows as inactive. Before rebooting, I do get a response 
from the router, however, I am unable to browse the web or ping anything 
outside of my network.  I am able to arp and see other nodes on my LAN.  I am 
also able to use a regular pcmcia wired card for browsing.  

 

Another thing to mention, the ACU reports that the card is associated with ip 
address: 00.00.00.00.  The strength signal is excellent, full bar.

 

Sorry to bore you fellows, but ive spent all weekend trying to fix this.  Im 
about to give up, please forgive my naivety when it comes to linux.

 

Spyro

Note You need to log in before you can comment on or make changes to this bug.