Bug 652659 - pexpect is not found in RHEL6-repository
pexpect is not found in RHEL6-repository
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-release-server (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Andrew Thomas
Release Test Team
: FutureFeature, Reopened
: 643299 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-12 08:35 EST by Gerrit Slomma
Modified: 2016-01-18 11:09 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 08:55:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerrit Slomma 2010-11-12 08:35:21 EST
Description of problem:

pexpect is (still) not found in RHEL6-repository.

Version-Release number of selected component (if applicable):

pexpect-2.3-6.el6.noarch.rpm

How reproducible:

Everytime via rhn-package-search or via yum list pexpect with mounted RHEL6-server install-cd

Steps to Reproduce:
1. search for pexpect in rhn, getting only RHEL4 and RHEL5-packages

> https://rhn.redhat.com/network/software/packages/name_overview.pxt?package_name=pexpect&archIdList=520&archLabelList=x86_64&search_subscribed_channels=

2. browse for it via channel-package-browse, not there either
3. look into Packages-directory on the RHEL6-server install-cd, it is there!
4. source-package is there too!
> http://ftp.redhat.com/redhat/linux/enterprise/6Server/en/os/SRPMS/pexpect-2.3-6.el6.src.rpm
  
Actual results:

No pexpect found

Expected results:

pexpect found

Additional info:

I hinted to this problem earlier in BUG 619566 for RHEL6-beta - but no one took me for real!

> https://bugzilla.redhat.com/show_bug.cgi?id=619566
Comment 2 Jan Friesse 2010-11-15 03:12:46 EST
Pexpect is available in High Availability repository. Server repository itself doesn't contain it.

Closing bug as NOTABUG, because pexpect should be used only by fence-agents package.
Comment 3 Gerrit Slomma 2010-11-15 11:08:42 EST
yumex from EPEL v6 has pexpect as a dependency, how to install this on a normal Server/Desktop?
Comment 4 Jan Friesse 2010-11-16 07:07:57 EST
I'm changing component to distribution, because bug is not in pexpect but in distribution.

Main problem seems to be, that pexpect is only used by fence-agents package and this is why it is only in HA. yumex is not supported in RHEL, but there may be chance to use it on server by customers.
Comment 5 Siddharth Nagar 2010-11-17 13:27:42 EST
*** Bug 643299 has been marked as a duplicate of this bug. ***
Comment 12 Mark Lamourine 2010-12-23 10:27:29 EST
As a frequent python coder, I think pexpect should pretty certainly be included in the server repository.  Of course this is only my opinion.  What are the criteria for inclusion other than direct requirement by something else that is included?
Comment 15 Gerrit Slomma 2011-01-14 03:43:56 EST
There seems to be an pexpect-2.3-6.el6.noarch.rpm on the RHEL6-Server-Install-CD, however it is not found in RHN?
Comment 16 Dennis Gregorovic 2011-01-14 14:33:08 EST
(In reply to comment #15)
> There seems to be an pexpect-2.3-6.el6.noarch.rpm on the
> RHEL6-Server-Install-CD, however it is not found in RHN?

It's in RHN, but not in the base channel.  In RHEL 6.0, pexpect is only available through the High Availability channel.  The goal of this package is to move the package into the base channel.
Comment 19 Alexander Todorov 2011-02-07 07:38:28 EST
# pwd
/mnt/redhat/nightly/RHEL6.1-20110206.n.0/6

# find -name "pexpect*" | sort
./Client/optional/i386/os/Packages/pexpect-2.3-6.el6.noarch.rpm
./Client/optional/source/SRPMS/pexpect-2.3-6.el6.src.rpm
./Client/optional/x86_64/os/Packages/pexpect-2.3-6.el6.noarch.rpm
./ComputeNode/optional/source/SRPMS/pexpect-2.3-6.el6.src.rpm
./ComputeNode/optional/x86_64/os/Packages/pexpect-2.3-6.el6.noarch.rpm
./Server/i386/os/Packages/pexpect-2.3-6.el6.noarch.rpm
./Server/i386/os/Server/Packages/pexpect-2.3-6.el6.noarch.rpm
./Server/optional/source/SRPMS/pexpect-2.3-6.el6.src.rpm
./Server/source/SRPMS/pexpect-2.3-6.el6.src.rpm
./Server/x86_64/os/Packages/pexpect-2.3-6.el6.noarch.rpm
./Server/x86_64/os/Server/Packages/pexpect-2.3-6.el6.noarch.rpm
./source/SRPMS/pexpect-2.3-6.el6.src.rpm
./Workstation/i386/os/Packages/pexpect-2.3-6.el6.noarch.rpm
./Workstation/i386/os/Workstation/Packages/pexpect-2.3-6.el6.noarch.rpm
./Workstation/optional/source/SRPMS/pexpect-2.3-6.el6.src.rpm
./Workstation/source/SRPMS/pexpect-2.3-6.el6.src.rpm
./Workstation/x86_64/os/Packages/pexpect-2.3-6.el6.noarch.rpm
./Workstation/x86_64/os/Workstation/Packages/pexpect-2.3-6.el6.noarch.rpm


For Server and Workstation variants pexpect is on the system-admin-tools group in comps.xml. For the other variants it is in the optional repo. Moving to VERIFIED.
Comment 20 errata-xmlrpc 2011-05-19 08:55:22 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0540.html

Note You need to log in before you can comment on or make changes to this bug.