Bug 65274 - apmscript does not run anacron on start
Summary: apmscript does not run anacron on start
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-21 09:16 UTC by diego.santacruz
Modified: 2014-03-17 02:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 22:48:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description diego.santacruz 2002-05-21 09:16:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020326

Description of problem:
When a laptop with apmd is booted, anacron is not run. However, is suspended and
resumed it is. This has the inconvenient that if the laptop is not
suspended/resumed very often the anacron jobs will not run very often.
The start event of apmd should start anacron, in the same way as the resume
event does.

Version-Release number of selected component (if applicable):
apmd-3.0final-34

How reproducible:
Always

Steps to Reproduce:
1. boot laptop with apmd configured
2.
3.
	

Actual Results:  anacron is never run if the laptop does not go through a
suspend/resume cycle. Note that adding anacron as a service to start on boot is
not an option, since that would not prevent running anacron if the laptop is on
 batteries.

Expected Results:  Run anacron on the apmd start event. Maybe it would be of
interest to run it also when the power changes from battery to on-line (if
anacron is configured not to run on batteries).

Additional info:

Comment 1 Stan Tazuma 2003-02-08 01:56:35 UTC
I have a problem with anacron that is pertinent
to this bug report.   I have all cron-related
services turned off, including anacron.
When I suspend my laptop, then resume, I don't
want anacron to run.  Why should it, since it
is not an enabled service.


Comment 2 Bill Nottingham 2005-02-02 22:48:38 UTC
Closing out bugs on older unsupported releases. Apologies for any lack
of response. Please reopen if it persists on current releases such as
Fedora Core 3.


Note You need to log in before you can comment on or make changes to this bug.