Bug 65280 - LVM doesn't startup properly using lvm module
LVM doesn't startup properly using lvm module
Status: CLOSED DUPLICATE of bug 57563
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
All Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-05-21 08:18 EDT by ivan
Modified: 2014-03-16 22:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-30 09:20:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch to add the missing load of the lvm-mod module (632 bytes, patch)
2002-05-22 16:38 EDT, Gerd v. Egidy
no flags Details | Diff

  None (edit)
Description ivan 2002-05-21 08:18:50 EDT
Description of Problem:

When using a kernel compiled with the lvm module (not lvm compiled 
in), the checks for /proc/lvm in rc.sysinit fail, and so any LVM 
volumes fail to startup (and so the box does not complete a normal boot).

(Giving LVM as an option for install would be cool ;^)

Version-Release number of selected component (if applicable):

How Reproducible: Every time

Steps to Reproduce:
1. Use RedHat kernel
2. Create LVM volume group, logical partition
3. Create a filesystem on the LV, and mount it at boot (in fstab).

Actual Results:
Machine doesn't complete boot, as it can't mount the filesystem on 
the LV.

Expected Results:
The VG should have been started, and the filesystem should have 
been recognised and mounted at boot.

Additional Information:
It doesn't seem to sit in high-severity, but it is quite important 
as it means that machines setup in this way cannot complete a boot.
Comment 1 Gerd v. Egidy 2002-05-22 16:37:10 EDT
I've been hit by this bug too.

It is because the rc.sysinit script looks for an existing /proc/lvm directory
before activating the vg. But if lvm is not compiled into kernel but compiled as
module (as in the default kernel package) /proc/lvm is not there until lvm-mod
is loaded.

The attached patch fixes this problem.
Comment 2 Gerd v. Egidy 2002-05-22 16:38:36 EDT
Created attachment 58245 [details]
patch to add the missing load of the lvm-mod module
Comment 3 Eric Hopper 2002-05-30 09:20:12 EDT
This is a duplicate of Bug# 57563
Comment 4 Bill Nottingham 2002-06-12 03:10:01 EDT

*** This bug has been marked as a duplicate of 57563 ***

Note You need to log in before you can comment on or make changes to this bug.