This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 652833 - perl-XML-Dumper missing dependencies
perl-XML-Dumper missing dependencies
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-XML-Dumper (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jitka Plesnikova
Jan Kepler
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-12 16:55 EST by Eric Eisenhart
Modified: 2014-01-30 04:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Using of the module perl(XML::Dumper) failed due to missing dependency. Consequence: perl(XML::Parser) is not listed in rpm dependencies Fix: Update spec file. Result: perl-XML-Dumper requires perl(XML::Parser). Using of perl(XML::Dumper) works properly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 10:43:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Eisenhart 2010-11-12 16:55:52 EST
Description of problem:
perl-XML-Dumper package is missing the perl() dependencies required for it to actually work.  In particular, perl(XML::Parser).

Version-Release number of selected component (if applicable):
perl-XML-Dumper-0.81-6.el6.noarch

How reproducible:
yum install perl-XML-Dumper
perl -MXML::Dumper -e 0
rpm -q --requires perl-XML-Dumper

Steps to Reproduce:
yum install perl-XML-Dumper
perl -MXML::Dumper -e 0
rpm -q --requires perl-XML-Dumper
  
Actual results:
# perl -MXML::Dumper -e 0
Can't locate XML/Parser.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/share/perl5/XML/Dumper.pm line 144.
BEGIN failed--compilation aborted at /usr/share/perl5/XML/Dumper.pm line 144.
Compilation failed in require.
BEGIN failed--compilation aborted.

# rpm -q --requires perl-XML-Dumper
perl(:MODULE_COMPAT_5.10.1)  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
rpmlib(PayloadIsXz) <= 5.2-1

Expected results:
# perl -MXML::Dumper -e 0
(should return nothing)

# rpm -q --requires perl-XML-Dumper
perl(:MODULE_COMPAT_5.10.1)  
perl(Exporter)  
perl(XML::Parser)  
perl(overload)  
perl(strict)  
perl(warnings)  

(all the other perl() dependencies are provided in the perl package, but perl(XML::Parser) is in perl-XML-Parser)
Comment 2 Marcela Mašláňová 2010-11-15 02:48:32 EST
The perl-XML-Parser is included in RHEL-6, it's missing only in spec file. This should be easy fix, thanks for report.
Comment 3 Suzanne Yeghiayan 2011-02-15 16:45:13 EST
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.
Comment 14 errata-xmlrpc 2013-05-20 10:43:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0838.html

Note You need to log in before you can comment on or make changes to this bug.