Bug 65285 - Changing KDM background has no effect
Summary: Changing KDM background has no effect
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinitrc (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-21 14:19 UTC by Eaden McKee
Modified: 2007-04-18 16:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 09:54:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eaden McKee 2002-05-21 14:19:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
I change the KDM background for the login screen. When I reboot, and X and kdm start, the background is there, but within a second it is overwritten with the redhat KDM background. 

So It loads the background, then loads the redhat background on top.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Change KDM background in login manager
2.reboot / logout
3. watch as the background loads, then is overwritten with the red hat kdm background.
 

Expected Results:  Loads KDM background. 

Additional info:

Comment 1 Bernhard Rosenkraenzer 2002-05-21 14:25:08 UTC
This is because /etc/X11/xdm/Xsetup_0 invokes xsri to draw a new background 
unconditionally.

Comment 2 Warren Togami 2002-05-22 10:23:56 UTC
Would it be correct for KDM load the Red Hat background by default, and not run
xsri?


Comment 3 Mike A. Harris 2002-08-08 09:46:08 UTC
I have polled internal development for suggestions on how to best handle
this.  I think removing the xsri call completely might be best.

Comment 4 Mike A. Harris 2002-12-15 09:51:41 UTC
Defering bug.

Comment 5 Mike A. Harris 2004-07-07 21:24:00 UTC
Is this issue still relevant in Fedora Core 2?


Note You need to log in before you can comment on or make changes to this bug.