Bug 652896 - LTSP still unsupported on Fedora 14
Summary: LTSP still unsupported on Fedora 14
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: ltsp
Version: 14
Hardware: Unspecified
OS: Linux
low
medium
Target Milestone: ---
Assignee: DaGeek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 674381 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-13 11:54 UTC by Adrie Taniwidjaja
Modified: 2012-08-16 18:14 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-16 18:14:50 UTC
Type: ---


Attachments (Terms of Use)
Missing files of ltsp kickstart for f13 and f14 (3.46 KB, application/zip)
2011-02-18 09:49 UTC, Tomas Straupis
no flags Details
One more missing file for f13/f14 (1.14 KB, text/plain)
2011-02-18 09:51 UTC, Tomas Straupis
no flags Details
Patch for upstream ltsp-trunk (1.33 KB, patch)
2011-02-24 15:17 UTC, Tomas Straupis
no flags Details | Diff
ltsp-build-client fc14 not supported (546 bytes, application/x-java-keystore)
2011-05-23 11:48 UTC, gabri032004
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 598134 0 low CLOSED [LTSP] ltsp-build-client :ERROR: fc13 is unsupported 2021-02-22 00:41:40 UTC

Internal Links: 598134 674381

Description Adrie Taniwidjaja 2010-11-13 11:54:28 UTC
Until Fedora 14 has been roll on it seems that LTSP still not supported.

When will Fedora support LTSP ?
This is very important feature for us but it seem it has been neglected by the package maintainer.

Comment 1 DaGeek 2010-11-15 14:18:24 UTC
I had created .rpm's for LTSP on F13 (https://bugzilla.redhat.com/show_bug.cgi?id=598134) and got some great feedback about them.
I'm sure i can roll them to F14 as well in the next week or so (I am in Milan this week away from my test boxes)

Warren did seem to come back to Fedora/LTSP (https://bugzilla.redhat.com/show_bug.cgi?id=598134#c23) but again has gone quite, I stopped working on the .rpm's when he came back, But looks like i might get to work on them, and this time try and push my .rpm's up into the Official Repos.

-- 
Gavin Spurgeon.
gspurgeon@redhat.com
Red Hat GLS Instructor EMEA
Red Hat UK Ltd
64 Baker Street
4th Floor, London, W1U 7DF
Mob:	+44 7841 231160
Desk:	+44 0207 009 4429 (Direct)
Tel:    +44 1252 362709
Fax:    +44 1252 548116


Registered in England and Wales under Company Registration No. 03798903
Directors: Michael Cunningham (USA), Brendan Lane (Ireland), Matt Parson
(USA), Charlie Peters (USA)

Comment 2 q2dg 2010-11-30 00:17:09 UTC
Hi.
Anyone knows anything about the state of this issue?
Could it be possible having Ltsp 5.2.4 running on Fedora 14?
I think it's a genial technology, and I don't know another alternative.
Many thanks

Comment 3 Kent 2010-12-01 17:02:03 UTC
I've used Gavin's RPM's on F13 and they work perfectly on newer hardware.  Thank you for all you've done!

They do not work on older hardware (specifically Diskless Workstation LTSP-150, which use a via chip), because the LTSP kernel requires 'cx8' and 'cmov', and apparently the via chip lacks them.

I attempted to create a new kernel but have had no luck so far.  It's been a *long* time since I rolled my own kernel.

Comment 4 Bruno Larini 2010-12-08 22:22:29 UTC
Even if the missing configuration files are adapted from other releases, it still misses the package 'system-config-display'. As far as I know this package became obsolete on fc14.
Can't the package be maintained for compatibility reasons?

Comment 5 q2dg 2010-12-08 22:45:30 UTC
Well, I think if a package is obsolete, it's better to forget it and to get another way of achieving the same results with other packages or procedures, don't you?

Comment 6 Bruno Larini 2010-12-08 23:28:29 UTC
For the present time, is there any known workaround? Or is it better to use some previous version (12,13)?

Comment 7 DaGeek 2010-12-10 10:42:41 UTC
My .rpm's should work on F13 without issue.

I will be working on both updating the F13 .rpm's and trying to see if there is any way to get LTSP working on F14 soon.

Please have a look @ the BZ for F13 for my .rpm's

https://bugzilla.redhat.com/show_bug.cgi?id=598134

I will also be trying to get my .rpm's added to the official F13 Repos very soon.

-- 
Gavin Spurgeon.
gspurgeon@redhat.com
Red Hat GLS Instructor EMEA
Red Hat UK Ltd
64 Baker Street
4th Floor, London, W1U 7DF
Mob:	+44 7841 231160
Desk:	+44 207 009 4429 (Direct)
Tel:    +44 1252 362709
Fax:    +44 1252 548116


Registered in England and Wales under Company Registration No. 03798903
Directors: Michael Cunningham (USA), Brendan Lane (Ireland), Matt Parson
(USA), Charlie Peters (USA)

Comment 8 q2dg 2010-12-10 11:46:09 UTC
Thanks!!
...but I can't believe that this so wonderful project is managed by only one person without any other support. It's so frustrating!

Comment 9 Eric moreau 2010-12-26 20:17:50 UTC
I'm starting to experiment with F14 on Dageek repo

(my goal is to boot through pxe-kexec from old laptops
 using wireless)

I already successfully booted F13 on wired Ethernet,
and I walked into the system-config-display problem for F14

In /etc/ltsp/kickstart/Fedora/common/release/14.ks

add the following in the %packages section

-system-config-display
-kudzu

This will get rid of system-config-display and kudzu.
So far I booted F14 but I haven't had time to test it much.

Comment 10 q2dg 2011-02-12 20:32:39 UTC
WILL SOMEONE DO SOMETHING ABOUT THIS SOME DAY??
Many "identity crisis" blogs have been written these days, but the most important things still are waiting...These real facts make Fedora less powerful.
Thanks.

Comment 11 Eric moreau 2011-02-12 22:53:58 UTC
(In reply to comment #10)
> WILL SOMEONE DO SOMETHING ABOUT THIS SOME DAY??
> Many "identity crisis" blogs have been written these days, but the most
> important things still are waiting...These real facts make Fedora less
> powerful.
> Thanks.

Well, ROLL UP YOUR SLEEVES AND SPIT IN YOUR HANDS, buddy!

You're greatly welcome to help with something else
than comments.

Comment 12 q2dg 2011-02-13 00:02:10 UTC
I'm only talking about catching code from 
https://code.launchpad.net/~ltsp-upstream/ltsp/ltsp-trunk
and packaging it for Fedora.
I don't thing it's a great effort, but I'm not a packager.
I only complain about a lack of interest in a piece of software I consider very strategical...and while many people waste their time doing philosophy, there are many real problems in real life to solve.
Only this.

Comment 13 DaGeek 2011-02-18 09:20:32 UTC
*** Bug 674381 has been marked as a duplicate of this bug. ***

Comment 14 Tomas Straupis 2011-02-18 09:44:53 UTC
Replying to comments on duplicate bug 674381

> where did you get the F13 .rpm's from ?
  Official repository for f14 (yes, released dir still has f13 version of this rpm).

> My biggest issue is trying to get my packages into the Official
> Fedora Repos. Just because I work for Red Hat does not mean I
> can get round the official procedures. So this is taking a long
> time. :-(
  That is sad because apparently people have fixed this package and it does work on f14 and f13 (there is still an open bug 598134).

  I will re-attach patches which make ltsp work on f14 as well as f13 (comments on this bug were used to make that patch).

Comment 15 Tomas Straupis 2011-02-18 09:49:03 UTC
Created attachment 479475 [details]
Missing files of ltsp kickstart for f13 and f14

I have a running ltsp installation on f14. Standard installation (f14/13
package) does not have kickstart files for f14 (and the ones for f13 are using
rawhide repositories).

Files in the archive are the ones I needed to fix this (I'm using i386
architecture, but I've tried to fix files for other architectures as well).
These files go under /etc/ltsp/kickstart/Fedora/.

P.S. I'm not sure if ppc architecture is still supported by fedora, if not, all
*ppc* files should be thrown out.

Comment 16 Tomas Straupis 2011-02-18 09:51:29 UTC
Created attachment 479476 [details]
One more missing file for f13/f14

This file should also be updated (f13 and f14 records are added).
This file goes to /etc/sysconfig/.

Comment 17 mahdi 2011-02-21 06:09:02 UTC
hi Tomas Straupis
i do your guide and ltsp-build-client work in my fedora 14
i run ltsp-build-client an get client from internet without any problem.
thank you

Comment 18 mahdi 2011-02-22 15:54:46 UTC
hi 
i install ltsp on fedora 14 and boot client successfully
 i see login screen of k12linux but i do not know what user and password i must use for login
when i use host user for login i after a long time i get this message
"no response from server restarting"

Comment 19 Tomas Straupis 2011-02-24 15:17:11 UTC
Created attachment 480779 [details]
Patch for upstream ltsp-trunk

This patch can be applied to upstream ltsp-trunk. This then results building rpm's with fedora13/14 support.

Comment 20 gabri032004 2011-05-23 11:48:50 UTC
Created attachment 500400 [details]
ltsp-build-client fc14 not supported

Comment 21 q2dg 2011-05-23 11:59:39 UTC
I've lost interest about this issue.
Maybe the future is SPICE: http://spice-space.org ...I hope

Comment 22 Warren Togami 2011-05-24 21:15:07 UTC
Hey folks,

https://fedorahosted.org/k12linux/wiki/EL6Status
Rapid development is now underway for EL6-based LTSP, which should be a lot more useful than any Fedora-based LTSP.  While Fedora is not the primary goal, Fedora 14 is similar enough to EL6 that fixes should be useful to smooth the experience of both distributions.  I will be pushing Fedora 14 support of LTSP into upstream and Fedora proper after I get around to fully testing it and smoothing out bugs.

https://fedorahosted.org/k12linux/wiki/2011FundDrive
Donations would help to make this a reality sooner.

And yes, I agree SPICE is the future.  That is my next project after EL6-based LTSP is mature.

Comment 23 Adrie Taniwidjaja 2011-06-20 14:22:07 UTC
Dear Warren,

I don't think SPICE will replace LTSP. According to what I know SPICE is just another protocol to compete and maybe replace rdesktop or vncviewer to give a real user experience when connected to a virtual desktop host from the client device. The client have to boot from itself before connecting to the virtual desktop.

Meanwhile the most important feature of LTSP according to my opinion is to convert a diskless PC to be a client for doing remote X login to one host. The client just execute a PXE Boot that was a very small program to download the boot image from the server. This is the main difference. We could use many old PC to become the client meanwhile SPICE doesn't care about how the client booting, which means the client should boot from a normal PC or special kind of client that factory preconfigure to do that. We could not use old PC to do that.

With LTSP all the client login to one host, that means one user credential and one instance of Linux OS. This is very important feature that needed by a site with ordinary administrator. While to make SPICE work we have to setup a virtualization, we manage an enough amount of virtual desktop  instance and we have to setup advanced user managament using something like NIS or may be LDAP. This kind complexity need a very skillfull administrator.

So I hope you still continue to developed and support LTSP. What I can suggest to you is to find the possibility maybe SPICE could be used by LTSP to give it an alternative protocol when the client login to the host. But I don't know if that is possible because SPICE connected and communicate at the driver level meanwhile LTSP used normal X remote login encapsulated under SSH.

Ubuntu with it's Edubuntu project do a very excellent LTSP support, even they could configure it on live CD. I hope Fedora could have this feature also because doing an LTSP installation on Fedora was very painfull especially if we have a very limited internet bandwidth connection. LTSP still needed by many developing country to support and facilitate the community to used old PC.

Please consider about this and hope this could energize you to hurry up on pushing the LTSP to the upstream Fedora.

Comment 24 Fedora End Of Life 2012-08-16 18:14:53 UTC
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.