Bug 652916 - [abrt] lxmusic-0.4.2-1.fc13: find_root: Process /usr/bin/lxmusic was killed by signal 11 (SIGSEGV)
[abrt] lxmusic-0.4.2-1.fc13: find_root: Process /usr/bin/lxmusic was killed b...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: lxmusic (Show other bugs)
13
i686 Unspecified
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:5a91f5b164d5d42b3e796a0c166...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-13 09:05 EST by nomnex
Modified: 2010-11-28 08:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-27 13:21:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (12.14 KB, text/plain)
2010-11-13 09:05 EST, nomnex
no flags Details

  None (edit)
Description nomnex 2010-11-13 09:05:38 EST
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: lxmusic
comment: I simply created a new playlist and select about 60 .mp3 files in 3 directories.
component: lxmusic
crash_function: find_root
executable: /usr/bin/lxmusic
kernel: 2.6.34.7-61.fc13.i686
package: lxmusic-0.4.2-1.fc13
rating: 4
reason: Process /usr/bin/lxmusic was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1289656896
uid: 500

How to reproduce
-----
1. Create a new playlist
2. Select some directories with audio files (.mp3) -- ~50 files
3. LxMusic crashed
Comment 1 nomnex 2010-11-13 09:05:41 EST
Created attachment 460232 [details]
File: backtrace
Comment 2 Christoph Wickert 2010-11-17 16:46:31 EST
Thanks for reporting this bug. Do you have the xmms2-mp3 package installed? Does lxmusic crash all the time or was it a singular crash?
Comment 3 Christoph Wickert 2010-11-25 15:04:01 EST
(In reply to comment #2)
> Do you have the xmms2-mp3 package installed?

The package is called xmms2-mad. Anything on the questions I asked?
Comment 4 nomnex 2010-11-26 11:26:48 EST
Christoph, xmms2-mad is installed. A Single crash so far.
Comment 5 Christoph Wickert 2010-11-27 13:21:58 EST
Thanks for the feedback.

I have forwarded your crash report to the lxmusixc developer at 
https://sourceforge.net/tracker/?func=detail&aid=3120751&group_id=180858&atid=894869

Frankly speaking I'm not too optimistic he will take care of it because lxmusic 0.4.2 is outdated. On the other hand I cannot update F13 to 0.4.4 as it requires a xmms2 >= 0.7.0.

Since it was only a single crash I suggest to simply consider this fixed in F14. If upstream takes care of your bug I will get back to you and ask for more info (if necessary). I will inform you when the bug is fixed in Fedora.

Thanks for taking the time to report this bug.
Comment 6 nomnex 2010-11-28 08:53:07 EST
and thanks in return for the details.  I will update to F14 in a months, when I have some free time.

Note You need to log in before you can comment on or make changes to this bug.