Bug 6530 - Failing to reboot system after setting quotas results in delayed system death
Summary: Failing to reboot system after setting quotas results in delayed system death
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-30 09:43 UTC by tom
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-04 22:26:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description tom 1999-10-30 09:43:13 UTC
We recently setup two identical RH61 servers (mail and POP
servers). We configured quotas using linuxconf, one system
we left in place, the other system had to be powered off and
moved to a different rack. Both systems have the same number
of users (we have an administration system that balances
users as they are added/removed). They have similar load and
each has ~5000 users each with a home directory and a mail
spool quota.

On the console of the non-rebooted system, the kernel slowly
printed these messages (since they didn't seem harmful we
just left it alone. However, as you read down, there's a VFS
file-max limit warning and after that it was impossible for
the system to spawn new processes.

Oct 29 20:30:06 grey kernel: get_empty_dquot: pruning 376
Oct 29 20:41:52 grey kernel: get_empty_dquot: pruning 488
Oct 29 20:49:46 grey kernel: get_empty_dquot: pruning 414
Oct 29 21:00:00 grey kernel: get_empty_dquot: pruning 478
Oct 29 21:19:57 grey kernel: get_empty_dquot: pruning 381
Oct 29 22:37:42 grey kernel: get_empty_dquot: pruning 524
Oct 29 23:09:59 grey kernel: get_empty_dquot: pruning 404
Oct 29 23:29:47 grey kernel: get_empty_dquot: pruning 399
Oct 30 02:07:27 grey kernel: get_empty_dquot: pruning 132
Oct 30 12:19:33 grey kernel: get_empty_dquot: pruning 128
Oct 30 12:19:47 grey kernel: get_empty_dquot: pruning 128
Oct 30 12:19:47 grey kernel: get_empty_dquot: pruning 565
Oct 30 12:37:50 grey kernel: get_empty_dquot: pruning 556
Oct 30 12:47:41 grey kernel: get_empty_dquot: pruning 337
Oct 30 12:58:21 grey kernel: get_empty_dquot: pruning 436
Oct 30 13:07:38 grey kernel: get_empty_dquot: pruning 481
Oct 30 13:29:01 grey kernel: get_empty_dquot: pruning 790
Oct 30 14:16:15 grey kernel: get_empty_dquot: pruning 507
Oct 30 14:47:58 grey kernel: VFS: file-max limit 4096
reached
Oct 30 14:49:00 grey kernel: Unable to load interpreter
Oct 30 14:54:44 grey kernel: Unable to load interpreter
Oct 30 14:59:04 grey kernel: Unable to load interpreter

The rebooted system is still working fine.

Comment 1 Cristian Gafton 2000-01-04 22:26:59 UTC
Assigned to dledford

Comment 2 Alan Cox 2000-08-22 18:58:49 UTC
6.1 certainly had problems with quotas. If the 6.2 erratakernel shows the same
ever, then
re-open the bug.



Note You need to log in before you can comment on or make changes to this bug.