Bug 65300 - GL screensavers atlantis freezes display, others don't work
GL screensavers atlantis freezes display, others don't work
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: screensaver
  Show dependency treegraph
 
Reported: 2002-05-21 14:22 EDT by Gregg Lebovitz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-17 16:11:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregg Lebovitz 2002-05-21 14:22:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
running xscreensaver-demo and displaying atlantis causes the screen to blank and
then become unresponsive. Keyboard commands, including <ctrl>-<alt>-<f1> have no
effect. The cursor continues to follow mouse movement, but mouse clicks have no
effect.

displaying the screensaver "pipes" displays the error:
pipes: sis_mesa.c: sis_SetDrawBuffer: Assertion `0' failed.
xscreensaver: child pid <nnn> (pipes) terminated with SIGABRT.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run xscreensaver-demo
2.select pipes or atlantis
3.press the demo button
	

Actual Results:  if atlantis is selected, the screen blanks and freezes. if
pipes is selected it returns the error:
pipes: sis_mesa.c: sis_SetDrawBuffer: Assertion `0' failed.
xscreensaver: child pid <nnn> (pipes) terminated with SIGABRT.




Expected Results:  full screen display of selected screensavers.

Additional info:

This a appears to be system specific:
Motherboard: Asus A7S-VM
CPU: Athlon 1.1 Ghz.
VGA adapter: Integrated SIS 630 display (SIS 730 chipset)
Video Memory: 32 Meg (trying with 8 Meg gives an out of memory error).
Comment 1 Gregg Lebovitz 2002-05-21 18:06:19 EDT
upgrading Gnome to the Ximian Desktop fixes the problem with the "pipes"
screensaver, but doesn't affect the problem with the "atlantis" screensaver.

The problem with the "atlantis" screensaver is critical since it hangs my
desktop and cannot be corrected by killing X or gdm. 


Comment 2 Bill Nottingham 2002-05-22 12:21:03 EDT
This is almost certainly an issue with the XFree86 drivers, or possibly the
kernel DRM drivers.
Comment 3 Mike A. Harris 2002-05-26 00:23:20 EDT
Disable DRI in your X config, and report back if the problem goes away.
Comment 4 Gregg Lebovitz 2002-05-29 12:00:34 EDT
Disabled the DRI modules and it corrected the problem.
Comment 5 Mike A. Harris 2002-09-12 00:39:07 EDT
This problem is believed to be fixed now, and affected pretty much
all DRI enabled drivers.  Please test the latest rawhide X and
kernel either using the Red Hat Linux (Null) beta, or once the new
release of Red Hat Linux is completed and released.  After testing
this out with our latest kernel/X, please provide updated status, and
if the problem persists, please attach your X server log and config
file.

Please test this out with DRI enabled to see if it works properly
with the latest package releases.
Comment 6 Mike A. Harris 2002-12-17 16:11:31 EST
Assuming problem is fixed in current kernel update as described above
due to lack of response.

Closing as ERRATA.

Note You need to log in before you can comment on or make changes to this bug.