Bug 653012 - F14 DVD Screen goes blank at start of install process.
Summary: F14 DVD Screen goes blank at start of install process.
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa
Version: 14
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: [cat:modesetting]
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-14 04:31 UTC by Tim Kitsos
Modified: 2018-04-11 17:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-15 18:16:10 UTC
Type: ---


Attachments (Terms of Use)
f14 dmesg (54.86 KB, text/plain)
2010-11-14 04:31 UTC, Tim Kitsos
no flags Details
f14 anaconda X.log (68.66 KB, text/plain)
2010-11-14 04:33 UTC, Tim Kitsos
no flags Details
f14 messages (544.97 KB, text/plain)
2010-11-14 04:34 UTC, Tim Kitsos
no flags Details
f14 xorg.conf (148 bytes, text/plain)
2010-11-14 04:35 UTC, Tim Kitsos
no flags Details
f14 xorg.0.log (69.89 KB, text/plain)
2010-11-14 04:36 UTC, Tim Kitsos
no flags Details
f14 xorg.9.log (70.40 KB, text/plain)
2010-11-14 04:37 UTC, Tim Kitsos
no flags Details
f14 smolt profile (6.41 KB, text/plain)
2010-11-14 04:38 UTC, Tim Kitsos
no flags Details

Description Tim Kitsos 2010-11-14 04:31:55 UTC
Created attachment 460302 [details]
f14 dmesg

Description of problem: 
Installing F14 from commercial DVD.  I select "Install a new system..." stuff scrolls across screen then screen goes blank.  Wait a long time, then have to force power down.  I was able to install F14 with the "Install system with the basic video driver".  All previous versions of Fedora installed as "New" with no problem, including F13.  F14 DVD media tested as OK. I don't know if my system uses the embedded DisplayPort (eDP) standard.

Version-Release number of selected component (if applicable):

How reproducible: Everytime

Steps to Reproduce:
1. Insert DVD
2. Select "Install a new system..."
3. wait...Screen goes blank
  
Actual results: Screen goes blank at start of install process.

Expected results:
1. Insert DVD
2. Select "Install a new system..."
3. Test media screen displays
4. Select test media, etc. etc. complete total install.

Additional info:
HP Pavilion dv2617us Notebook 12/20/07
Model: dv2617us  Product: (1P)GS889UA Option (30P)ABA
Intel Graphics Media Accelerator x3100 upto 384MB shared video
1.5 GHz Centrino Duo Core 2 T5250  2M
Mobile GM965/GL960 Integrated Graphics Controller

Comment 1 Tim Kitsos 2010-11-14 04:33:40 UTC
Created attachment 460303 [details]
f14 anaconda X.log

Comment 2 Tim Kitsos 2010-11-14 04:34:43 UTC
Created attachment 460304 [details]
f14 messages

Comment 3 Tim Kitsos 2010-11-14 04:35:32 UTC
Created attachment 460305 [details]
f14 xorg.conf

Comment 4 Tim Kitsos 2010-11-14 04:36:18 UTC
Created attachment 460306 [details]
f14 xorg.0.log

Comment 5 Tim Kitsos 2010-11-14 04:37:05 UTC
Created attachment 460307 [details]
f14 xorg.9.log

Comment 6 Tim Kitsos 2010-11-14 04:38:09 UTC
Created attachment 460308 [details]
f14 smolt profile

Comment 7 Herbert Bosshardt 2010-11-15 08:22:27 UTC
Same Error when trying to replace (install new ...) F12 with F14 on Dell Inspiron 1525 Core 2 Duo T8100 (used as dual boot system). 
Downloaded the F14 DVD-iso-files (32-bit and 64-bit) from the Fedora Download page. Both passed the sha256sum check. 
The last two lines on the screen are 'running sbin/loader' and 'waiting for hardware ..(here are some more words)...' then the screen turns black. Applies to both the 32-bit and 64-bit version).

On Inspiron 8200 and 9300 on the other hand the installation looks to run normal. This means it continued up to the media check.  The media check passed. (there I stopped the installation manually).

Comment 8 Matěj Cepl 2010-11-16 00:31:54 UTC
(In reply to comment #3)
> Created attachment 460305 [details]
> f14 xorg.conf

Fedora 14 11/13/10

[root@localhost X11]# cat xorg.conf
Section "Device"
	Identifier "Videocard0"
	Driver "vesa"
EndSection
[root@localhost X11]# 

Why do you set up VESA manually? What would happen if you remove (gzip or get out of the way by some other means) /etc/X11/xorg.conf and restart Xorg?

Comment 9 Tim Kitsos 2010-11-17 04:34:50 UTC
(In reply to comment #8)
.
Thanks for your help. I haven't done anything manually other than select the 2nd option on the DVD installation disk: "Install system with the basic video driver".  I'm assuming that the "vesa" must be that basic driver. I can probably live with that driver. I just thought I should report it since all the previous versions of Fedora worked with the 1st selection on the DVD install disk: "Install a new system or upgrade an existing system."  I'm not aware of any problems yet with this driver other than the start up and shut down don't seem to be very graceful with screen flashes and scrolling code compared to previous versions. The blank screen with no feed back doesn't seem like it should be normal for selection #1 failure. If this is just the way it is, I guess there is no bug.

I'm not sure what you want me to do: "What would happen if you remove (gzip or get out of the way by some other means) /etc/X11/xorg.conf and restart Xorg?"  

Thanks again.

Comment 10 Tim Kitsos 2011-07-15 01:20:50 UTC
Please close this bug. Never got it to work on F14, worked on F13. I've moved on to Fedora 15 with no problems related to this bug.

Comment 11 Matěj Cepl 2011-07-15 18:16:10 UTC
Thank you for letting us know.


Note You need to log in before you can comment on or make changes to this bug.