Bug 653018 - Incorrect font rendering for Chinese text in Thunderbird mail text area
Summary: Incorrect font rendering for Chinese text in Thunderbird mail text area
Keywords:
Status: CLOSED DUPLICATE of bug 653017
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 14
Hardware: Unspecified
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-14 05:24 UTC by Cong Ma
Modified: 2010-11-14 05:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-14 05:26:49 UTC
Type: ---


Attachments (Terms of Use)

Description Cong Ma 2010-11-14 05:24:40 UTC
Description of problem:
For some reason I need to run the desktop under zh_CN.utf8 locale but Thunderbird under en_US.utf8.  When doing so, the mail text displayed in Thunderbird gets incorrect font rendering.  For all plain text mails, the Characters are displayed in a mixed fonts of WenQuanYi Zen Hei and AR PL UKai (see screenshot).  This affects all mail directories as well as the mail composition window, but the effect is limited to mail body text.  Subjects are not affected.

If Thunderbird is run under locale zh_CN.utf8, there's no inconsistency with mail body font.


Version-Release number of selected component (if applicable):
thunderbird-3.1.6-2.fc14.x86_64


How reproducible:
Always (under locale en_US.utf8)


Steps to Reproduce:
1.  Run Thunderbird with LC_ALL=en_US.utf8
2.  Read or compose plain text emails with Chinese characters

  
Actual results:
Chinese characters in message bodies are displayed in inconsistent fonts, greatly reducing readability. 


Expected results:
The fonts used should have been consistent.


Additional info:
This problem arises when the option "Use fixed width font for plain text messages" is selected.  This is my preferred setting, and the monospace font used is Nimbus Mono L.

I'm not sure whether this has anything to do with fontconfig.  I have not meddled with F14's default system-wide fontconfig settings.

Comment 1 Cong Ma 2010-11-14 05:26:49 UTC
Oops I accidentally submitted this bug twice.  Sorry for the noise in the e-mails.

*** This bug has been marked as a duplicate of bug 653017 ***


Note You need to log in before you can comment on or make changes to this bug.