Bug 653062 - [abrt] pitivi-0.13.5-1.fc14: singledecodebin.py:316:_unblockPad:TypeError: Parameter 'handler_id' must be an int or a long
Summary: [abrt] pitivi-0.13.5-1.fc14: singledecodebin.py:316:_unblockPad:TypeError: Pa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pitivi
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Chen Lei
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:cc9b5c50
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-14 10:34 UTC by unix63
Modified: 2010-12-25 00:25 UTC (History)
13 users (show)

Fixed In Version: pitivi-0.13.5-4.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-25 00:25:12 UTC


Attachments (Terms of Use)
File: backtrace (652 bytes, text/plain)
2010-11-14 10:34 UTC, unix63
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 613960 None None None Never

Description unix63 2010-11-14 10:34:56 UTC
abrt version: 1.1.13
architecture: i686
cmdline: python /usr/bin/pitivi
component: pitivi
executable: /usr/bin/pitivi
kernel: 2.6.35.6-48.fc14.i686
package: pitivi-0.13.5-1.fc14
reason: singledecodebin.py:316:_unblockPad:TypeError: Parameter 'handler_id' must be an int or a long
release: Fedora release 14 (Laughlin)
time: 1289730677
uid: 500

backtrace
-----
singledecodebin.py:316:_unblockPad:TypeError: Parameter 'handler_id' must be an int or a long

Traceback (most recent call last):
  File "/usr/share/pitivi/python/pitivi/elements/singledecodebin.py", line 328, in _padBlockedCb
    self._unblockPad(target=self._target)
  File "/usr/share/pitivi/python/pitivi/elements/singledecodebin.py", line 316, in _unblockPad
    target.remove_event_probe(self._eventProbeId)
TypeError: Parameter 'handler_id' must be an int or a long

Local variables in innermost frame:
self: <SingleDecodeBin object (pitivi+elements+singledecodebin+singledecodebin1) at 0x8a9a374>
target: <GstPad (ffdec_h2642:src) at b5f7b010>

How to reproduce
-----
1 Imported a video into the library
2.  Dragged the video from lthe library window onto the timeline.
3.

Comment 1 unix63 2010-11-14 10:34:59 UTC
Created attachment 460351 [details]
File: backtrace

Comment 2 Tim Waugh 2010-11-14 12:18:00 UTC
Package: pitivi-0.13.5-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


Comment
-----
Imported a MOV clip via the "Import clips..." button, then dragged the clip into the empty timeline.

Comment 3 copperjoy2002 2010-11-20 09:27:43 UTC
Package: pitivi-0.13.5-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


Comment
-----
I dragged a video onto the programme and it crashed.

Comment 4 neil hou 2010-11-24 11:55:10 UTC
Package: pitivi-0.13.5-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.add a movie
2.drop it to time line
3.it crashes

Comment 5 Hicham HAOUARI 2010-11-29 00:54:11 UTC
I just updated to latest git and I don't have this problem. Please update.

Comment 6 Chen Lei 2010-11-29 06:12:18 UTC
(In reply to comment #5)
> I just updated to latest git and I don't have this problem. Please update.

Would you mind to co-maintain or maintain pitivi?

Comment 7 Hicham HAOUARI 2010-11-29 12:49:09 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > I just updated to latest git and I don't have this problem. Please update.
> 
> Would you mind to co-maintain or maintain pitivi?

Ok, I will apply in pkgdb.

Comment 8 vikashagrawal1990 2010-12-07 01:10:13 UTC
Package: pitivi-0.13.5-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Adding mp3 to videos
2.
3.

Comment 9 Hicham HAOUARI 2010-12-08 12:54:59 UTC
I can't reproduce this bug anymore. Please try to give more details.

Comment 10 Jim 2010-12-12 18:27:27 UTC
Package: pitivi-0.13.5-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Added several mpegs to the media library (around 77)
2. Dragged the first mpeg to the timeline.
3. That's it!


Comment
-----
See step-by-step.
The size of the mpeg was 70.2 Mb.

Comment 11 Joost 2010-12-14 22:49:18 UTC
Package: pitivi-0.13.5-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Open PiTiVi 
2. Import a jpg and a ogg file
3. Arrange it and click export
4. Attempt to change settings
5. Crash

Comment 12 Fedora Update System 2010-12-15 13:19:23 UTC
pitivi-0.13.5-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pitivi-0.13.5-4.fc14

Comment 13 Fedora Update System 2010-12-17 08:26:29 UTC
pitivi-0.13.5-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pitivi'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/pitivi-0.13.5-4.fc14

Comment 14 Pedro Silva 2010-12-18 00:00:14 UTC
Package: pitivi-0.13.5-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Open Pitivi
2. Import Clip Video: 1280x720 H.264/AVC 30fps Audio: MPEG-4 AAC Audio Stereo 48000Hz 111kpbs (hak5--0725--defcon18--hd720p30.h264.mp4 - free downloadable video)
3. Crash

Comment 15 Fedora Update System 2010-12-25 00:24:46 UTC
pitivi-0.13.5-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.