Bug 653081 - RFE: Add updated rxvt-unicode terminfo
RFE: Add updated rxvt-unicode terminfo
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ncurses (Show other bugs)
rawhide
Unspecified Unspecified
low Severity high
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-14 08:23 EST by Andreas Bierfert
Modified: 2010-11-29 10:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-29 08:02:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Bierfert 2010-11-14 08:23:06 EST
rxvt-unicode has updated its terminfo for version 9.09.

Builds are waiting to get pushed to updates-testing for F13, F14 and F15.

Please update ncurses to include the new terminfo file asap so these updates can be pushed.

It is included as documentation in the rxvt-unicode build available here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2599959.

If possible the ncurses build could be added to the rxvt-unicode updates for F13 and F14.

If you want I can update the terminfo in ncurses myself.
Comment 1 Miroslav Lichvar 2010-11-15 04:11:34 EST
Is updating the terminfo entry in F13 and F14 really necessary? It seems that only the number of supported color pairs has changed recently, this shouldn't cause any problems.

Also, we are still using a very old version of the entry, because the new ones have some problems with screen. It would be nice to fix it first before the entry is updated.
Comment 2 Andreas Bierfert 2010-11-15 04:55:50 EST
Hm, it is explicitly mentioned int he changelog [1]:

9.09 Sat Nov 13 01:39:07 CET 2010
	- NOTICE: this release updates terminfo/termcap.


Could you elaborate on the problems with screen and what needs to be fixed? I need to contact upstream anyway because of libev. Maybe we can clarify this.


[1] - http://dist.schmorp.de/rxvt-unicode/Changes
Comment 3 Miroslav Lichvar 2010-11-15 07:03:55 EST
The relevant changelog entries seem to be:
- update rxvt-unicode terminfo to state 7744 colour pairs to cover all 88*88 possible pairs.
- add rxvt-unicode-256color terminfo and use it by default in 256 colors mode.

The first one is minor and probably doesn't warrant an ncurses update.

But the second one will be a problem. We can add the new entry in F13 and F14, but there are other systems which won't have it anytime soon and users connecting via ssh will be getting unknown terminal errors. Interestingly, screen doesn't work with rxvt-unicode-256color at all, it exits with "$TERM too long - sorry.", looks like a screen bug.

If possible, I'd suggest to not use the 256color entry by default, at least for a while, before it has a chance to spread a bit.

The problem with screen is when detaching/exiting, the original content of terminal is not resumed properly. I suspect this is caused by one of the changes in the initializations strings.
Comment 4 Andreas Bierfert 2010-11-15 10:03:02 EST
Thanks for the feedback.

The terminfo files are included in the package as doc so people can install/copy/... them to system where they are not available by default. However I will try to contact the maintainers in the other distros and try to coordinate this a bit. I will also try to contact upstream and get a statement as to the problems you pointed out.
Comment 5 Andreas Bierfert 2010-11-15 17:10:50 EST
Gentoo[1] has already included the new terminfo file an I have talked to upstream about it as well. The one from 9.09 should be good to get included into ncurses.

The too long problem is a screen bug.

Could you be more precise with the screen bugs (maybe open up a seperate bug against urxvt) so I can track the problems upstream can verify things?
Comment 6 Miroslav Lichvar 2010-11-16 06:55:51 EST
I can reproduce the screen problem with:
start screen
start mutt (or irssi or any fullscreen application)
exit mutt
exit screen

The terminal is now corrupted, there are parts of mutt visible.

But we can fix this later. If you feel strongly about using the 256color entry by default, I think we can make an update which will just add the new rxvt-unicode-256color entry.

BTW, it would be really nice if urxvt upstream worked with ncurses upstream to get the entries included in the ncurses database.
Comment 7 Andreas Bierfert 2010-11-16 13:48:14 EST
Hm I tried with mcabber which seems to work just fine here.

256color will not be the default.

I have split the rxvt-unicode package to provide four versions (somewhat like debian):

- standard (rxvt-unicode)
- multi-language support (rxvt-unicode-ml)
- 256color version (rxvt-unicode-256color)
- 256color multi-language (rxvt-unicode-256color-ml)

http://koji.fedoraproject.org/koji/buildinfo?buildID=205202

Aside from that it would be great to include it into ncurses.
Comment 8 Thomas E. Dickey 2010-11-19 04:15:26 EST
It's probably not a "bug in screen".  For instance, the name given
is longer than the standard 14-characters, and would be a nuisance.
I've grudgingly accepted a few obscure entries which don't comply.
It won't happen upstream for something that's used frequently.

I've a to-do to check over the latest entry, but infocmp lists
60 differences between my reference copy and urxvt's.  So there's
some adjustments which its maintainer would have to agree to before
I'd add it to ncurses.
Comment 9 Thomas E. Dickey 2010-11-21 15:38:40 EST
hmm - reviewing, there are several longer than 14 (some of
the "screen" variations for example).  The longest currently
is 21 characters, matching the length of this.  (I prefer
urxvt-256color of course, for the above-stated reason).

There are still a lot of differences between my reference copy
and urxvt's.
Comment 10 Andreas Bierfert 2010-11-22 13:20:19 EST
I'd be nice to stay compatible between distros. Gentoo has already included the terminfo shipped with 9.09: http://sourcestest.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-libs/ncurses/ncurses-5.7-r6.ebuild?view=log.

Could you elaborate more on the differences you are talking about?
Comment 11 Thomas E. Dickey 2010-11-22 13:27:37 EST
The majority of the difference is that it's not defining
the modified keys, e.g., as I've done in ncurses for several
years for terminals that support them (shift, control, etc.).
There are also some settings that are incorrect.

(ultimately, rxvt-unicode's maintainer should discuss those
differences - as I noted earlier, politely and accurately -
there's no point in my adding a corrected version of the
entry if he's not willing to own it in his code).
Comment 12 Andreas Bierfert 2010-11-22 13:57:05 EST
Did you discuss these problems with upstream?
Comment 13 Thomas E. Dickey 2010-11-22 18:08:02 EST
I read his response early this year, saw no difference from
for instance

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=265631

There's not much to work with.
Comment 14 Andreas Bierfert 2010-11-29 08:02:41 EST
rxvt-unicode-256color terminfo will be included with rxvt-unicode for now.
Comment 15 Miroslav Lichvar 2010-11-29 10:52:13 EST
The rxvt-unicode entry was updated to the latest version in ncurses-5.7-9.20101128.fc15.

Note You need to log in before you can comment on or make changes to this bug.