Bug 653106 - SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from getattr access on the file /home/tom/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol.
Summary: SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from getattr acce...
Keywords:
Status: CLOSED DUPLICATE of bug 653104
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:244e1eb644e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-14 15:38 UTC by Tom
Modified: 2010-11-15 11:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-15 11:51:35 UTC


Attachments (Terms of Use)

Description Tom 2010-11-14 15:38:25 UTC
SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from getattr access on the file /home/tom/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol.

*****  Plugin restorecon (99.5 confidence) suggests  *************************

If you want to fix the label, settings.sol does not have the default system label.
Then you can run restorecon.
Do
# /sbin/restorecon -v /home/tom/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If you want to allow npviewer.bin to have getattr access on the settings.sol file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep /usr/lib/nspluginwrapper/npviewer.bin /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                /home/tom/.macromedia/Flash_Player/macromedia.com/
                              support/flashplayer/sys/settings.sol [ file ]
Source                        npviewer.bin
Source Path                   /usr/lib/nspluginwrapper/npviewer.bin
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           nspluginwrapper-1.3.0-14.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.8-4.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 2.6.36-1.fc15.i686.PAE #1 SMP Thu
                              Oct 21 04:31:09 UTC 2010 i686 i686
Alert Count                   344
First Seen                    Sat 13 Nov 2010 05:38:16 PM EST
Last Seen                     Sun 14 Nov 2010 10:33:18 AM EST
Local ID                      395386ea-c1ca-4c13-be60-0e40d83ce612

Raw Audit Messages
type=AVC msg=audit(1289748798.124:1347): avc:  denied  { getattr } for  pid=4355 comm="npviewer.bin" path="/home/tom/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol" dev=dm-3 ino=3933078 scontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file

npviewer.bin,nsplugin_t,user_home_dir_t,file,getattr
type=SYSCALL msg=audit(1289748798.124:1347): arch=i386 syscall=stat64 success=no exit=EACCES a0=85486e8 a1=bfc533d0 a2=4d14fff4 a3=bfc534b0 items=0 ppid=4343 pid=4355 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm=npviewer.bin exe=/usr/lib/nspluginwrapper/npviewer.bin subj=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 key=(null)
npviewer.bin,nsplugin_t,user_home_dir_t,file,getattr

#============= nsplugin_t ==============
allow nsplugin_t user_home_dir_t:file getattr;

Comment 1 Miroslav Grepl 2010-11-15 11:51:35 UTC

*** This bug has been marked as a duplicate of bug 653104 ***


Note You need to log in before you can comment on or make changes to this bug.