Bug 653111 - SELinux is preventing /sbin/killall5 from getattr access on the file /usr/sbin/atd.
Summary: SELinux is preventing /sbin/killall5 from getattr access on the file /usr/sbi...
Keywords:
Status: CLOSED DUPLICATE of bug 653108
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:058052a34f8...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-14 15:41 UTC by Tom
Modified: 2010-11-16 01:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-15 08:40:34 UTC
Type: ---


Attachments (Terms of Use)

Description Tom 2010-11-14 15:41:06 UTC
SELinux is preventing /sbin/killall5 from getattr access on the file /usr/sbin/atd.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you want to allow killall5 to have getattr access on the atd file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep /sbin/killall5 /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:crond_exec_t:s0
Target Objects                /usr/sbin/atd [ file ]
Source                        pidof
Source Path                   /sbin/killall5
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           sysvinit-tools-2.88-1.dsf.fc15
Target RPM Packages           at-3.1.12-5.fc14
Policy RPM                    selinux-policy-3.9.8-4.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 2.6.36-1.fc15.i686.PAE #1 SMP Thu
                              Oct 21 04:31:09 UTC 2010 i686 i686
Alert Count                   8
First Seen                    Sat 13 Nov 2010 05:04:57 PM EST
Last Seen                     Sun 14 Nov 2010 09:54:27 AM EST
Local ID                      05f75edf-5132-4758-b96a-f8e0d83cdb06

Raw Audit Messages
type=AVC msg=audit(1289746467.737:57): avc:  denied  { getattr } for  pid=1391 comm="pidof" path="/usr/sbin/atd" dev=dm-1 ino=2126117 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:crond_exec_t:s0 tclass=file

pidof,xdm_t,crond_exec_t,file,getattr
type=SYSCALL msg=audit(1289746467.737:57): arch=i386 syscall=stat64 success=no exit=EACCES a0=bfb3047b a1=bfb2f36c a2=4d14fff4 a3=3 items=0 ppid=1388 pid=1391 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=pidof exe=/sbin/killall5 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)
pidof,xdm_t,crond_exec_t,file,getattr

#============= xdm_t ==============
allow xdm_t crond_exec_t:file getattr;

Comment 1 Miroslav Grepl 2010-11-15 08:40:34 UTC

*** This bug has been marked as a duplicate of bug 653108 ***


Note You need to log in before you can comment on or make changes to this bug.