Bug 65316 - xterm copy with mouse under KDE3
xterm copy with mouse under KDE3
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-21 17:21 EDT by Peter Toft
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-23 16:15:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Toft 2002-05-21 17:21:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
I use KDE3 with anti-aliased fonts (which seems not to work *sigh*)
and I see problems when having a set of lines which I like to copy.
I set the cursor on the first spot and press left mouse - fine - then
I drag to the last spot and release - fine. Then I can insert the text
into an editor - fine. 
Then if I go back to the same window the initial place of the select region is
always what was selected intially. The start place is sticky. This is a
*extremely* annoying bug. 

KDE konsole does not seem to have that bug.

This error *might* be connected to 64466 in some way

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.start xterm
2. select region with mouse
3. paste in an editor
4. re-select another region
	

Actual Results:  That the other region was selected.

Expected Results:  A region with wrong starting poing is selected.

Additional info:
Comment 1 Mike A. Harris 2002-05-22 06:49:55 EDT
Bero, have you gotten any reports of this behaviour?  Able to reproduce?
Comment 2 Bernhard Rosenkraenzer 2002-05-22 07:18:54 EDT
Haven't had any reports about this, and can't reproduce it either. 
 
On the comment that anti-aliased fonts aren't working: Read the release notes, 
they describe why it *looks like* they aren't working and what you can do 
about it.
Comment 3 Peter Toft 2002-05-23 16:15:33 EDT
I now remember another thing which might have caused the bug mentioned above.
My faithful friend "pine" seems buggy. I have something like 500 Mbyte of mail
distributed over 100 folders. I have now three times seen pine hanging right
after feeding mails into the system using formail (I use scp to move my
mail-folder from the mail-server to my local machine and locally use formail
to feed the mails through my procmail-filters - this has worked for several years).

Well I have seen pine stalling with "Opening mymail <->" for much longer time
than expected (no harddisk activity). Then I tried to kill pine with "pine PID"
that failed. Then "pine -9 PID" *also* failed, and I just now had to kill all of
KDE to get rid of the pine-process eating all of the CPU power. Killing KDE
removed the pine-process. The bug mentioned initially in this bug-report
happened right after such a problem with pine the other day.

I am sorry that I cannot be more specific, since it could be KDE, XFree, pine or
the kernel - or theoretically something else.
Comment 4 Mike A. Harris 2002-08-07 22:37:34 EDT
Sorry, but I am unable to reproduce this problem, so I can't possibly
debug and/or fix it if it is indeed a bug.  Someone who can reproduce
this will have to debug it fully to determine what exactly the problem
is and where the problem occurs - in xterm, pine, or elsewhere.
Comment 5 Warren Togami 2002-08-08 01:29:31 EDT
This is a real and known bug, but very difficult to reproduce.  I have
personally seen it only after using a KDE3 desktop in Skipjack and Valhalla for
24+ hours, after this point clipboard behavior would be erratic, sometimes
copying corrupted garbage into the clipboards (both select and clipboard),
sometimes select would stop functioning, sometimes clipboard would stop funcitoning.

After a complete X restart it would return to normal behavior... for a while.

I saw KDE3 clipboard problems being described in some dot.kde.org news reports
and comments, and one or two KDE3 reviews somewhere out there.

I don't know if this is fixed in the latest KDE versions.
Comment 6 Mike A. Harris 2002-08-08 02:37:13 EDT
If it is rare and hard to reproduce, it generally would be quite difficult
or impossible for us to spend time debugging and fixing anyway.  If it is
fixed in new KDE, then I would assume it isn't an XFree86 bug, but is
a KDE bug that was fixed.

So, on the chance the problem recurs, please reopen it against kdebase.

Thanks

Note You need to log in before you can comment on or make changes to this bug.