Bug 653169 - OpenJDK freezes Ameritrade Command Center with versions above 1.6.0.0-37
Summary: OpenJDK freezes Ameritrade Command Center with versions above 1.6.0.0-37
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-14 21:21 UTC by GoinEasy9
Modified: 2012-08-16 17:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-16 17:54:13 UTC
Type: ---


Attachments (Terms of Use)
xsession errors (1.44 MB, text/plain)
2010-11-15 01:52 UTC, GoinEasy9
no flags Details
console.log (130.34 KB, text/x-log)
2010-11-30 03:28 UTC, GoinEasy9
no flags Details
java.stderr (597.91 KB, text/plain)
2010-11-30 03:29 UTC, GoinEasy9
no flags Details
java.stdout (2.47 KB, text/plain)
2010-11-30 03:30 UTC, GoinEasy9
no flags Details
Screenshot when Command Center stalls. (1.42 MB, image/png)
2010-11-30 03:31 UTC, GoinEasy9
no flags Details
OpenJDK-test-build (530.72 KB, text/plain)
2010-12-09 02:58 UTC, GoinEasy9
no flags Details

Description GoinEasy9 2010-11-14 21:21:36 UTC
Description of problem: Launching Ameritrade Command Center halts when using a version above java-1.6.0-openjdk-1:1.6.0.0-37.b17.fc13


Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-44.1.9.1.fc14.i686

How reproducible:  Always, see steps below.


Steps to Reproduce:
1. Open either Firefox or Chrome
2. Login to Ameritrade
3. Launch Command Center
  
Actual results:  Command Center starts, charts and other stock monitoring windows open, but, before Command Center desktop is complete, windows freeze.  Updating of charts stop, some windows turn white, then, reappear after a mouse over. Further mouse clicks, especially trying to close windows make matters worse, freezing the windows that I'm trying to close.
I can exit out of the starting applet... window, log out of Ameritrade, and when I "X" out of either browser, Command Center finally closes.


Expected results:  Fully functioning Command Center.


Additional info: In F13 this started happening when openjdk-1.6.0.0-43 came in on 10/20/2010.  Downgrading to openjdk-1.6.0.0-37 solved the problem. I have excluded the java update on my F13 production machines every since hoping a subsequent update would take care of the problem.  Unfortunately, F14 doesn't have a 1.6.0.0-37 version to downgrade to.
I have just finished experimenting on F14 trying to find something in the logs that would show what is going on, again, unfortunately, nothing showed up in messages, and attempts to use gdb starting with firefox led to notifications of missing debuginfo's even after installing the ones I was notified to.
SELinux is enabled on half of my F13 production machines and disabled on the other half, and I see the same errors where it's enabled or disabled, so I can't point to that being the problem.
I'm not seeing any increase in CPU usage when the Command Center windows turn sluggish and eventually freeze.
I don't know if it's openjdk or the plugin that is causing the problem as upgrades and downgrades affect both.
I'm sorry I can't attach any other information, as I cannot get a backtrace and abrt is not notifying me of an error.
If there is something I'm missing that can help you solve the problem, please, point me in the right direction and I'll do what I can.
As an additional note, I am running F14 with SELinux enabled, and, I am prompted when trying to start Command Center by SELinux to give it permission to run.

Comment 1 GoinEasy9 2010-11-15 01:52:28 UTC
Created attachment 460447 [details]
xsession errors

I just noticed that my xsession-errors file is fill of output from this bug.

Comment 2 GoinEasy9 2010-11-28 21:37:33 UTC
I'm wondering if any progress has been made on this bug.  The last time OpenJDK malfunctioned with Command Center it was fixed quickly.  I would be happy to provide more information if you could point me where to look for it.
I'm also in a catch-22 situation.  In order to use the Android plugin for eclipse, I need to install eclipse version 3.5, which requires an update of OpenJDK to a version that will not work with Command Center.  I'm still excluding java* from my updates in order to trade stocks, but, I would like to use my machines for Android development also.

Comment 3 Deepak Bhole 2010-11-29 15:43:07 UTC
Hi. Can you please start firefox from command-line as follows:

ICEDTEAPLUGIN_DEBUG=true firefox 2>&1 | tee console.log

And then try to log in and attach the resulting console.log file and ~/.icedteaplugin/java.std* files? Please be sure to scan the files for any sensitive data first.

Comment 4 GoinEasy9 2010-11-30 03:26:38 UTC
Attached console.log, java.stderr java.stout and Ameritrade-stall.png.  Screenshot of stalled Command Center.  Charts form but surrounding information doesn't appear.  Window for options chain says "Loading" but never loads.  I can "X" out of Firefox and close the session, but other windows containing charts etc. are non responsive.

Comment 5 GoinEasy9 2010-11-30 03:28:13 UTC
Created attachment 463630 [details]
console.log

Comment 6 GoinEasy9 2010-11-30 03:29:36 UTC
Created attachment 463631 [details]
java.stderr

Comment 7 GoinEasy9 2010-11-30 03:30:24 UTC
Created attachment 463632 [details]
java.stdout

Comment 8 GoinEasy9 2010-11-30 03:31:42 UTC
Created attachment 463633 [details]
Screenshot when Command Center stalls.

Comment 9 GoinEasy9 2010-12-02 05:19:21 UTC
Just an update.  Tonight a new update came in.
java-1.6.0-openjdk-1.6.0.0-49.1.9.2.fc14.i686
Unfortunately, with similar results.

Comment 10 Deepak Bhole 2010-12-02 14:55:06 UTC
I think the problem has been fixed in the upstream plugin. Since a login in required to reproduce the issue, you will have to try it on your end.

Are you comfortable with compiling a newer version of IcedTea and the plugin? 

Firstly, you will have to run, as root:
yum-builddep java-1.6.0-openjdk

Then to build..

For IcedTea:
hg clone http://icedtea.classpath.org/hg/icedtea6
cd icedtea6
./autogen.sh
./configure
make

Once that is done. You will have to build icedtea-web:
hg clone http://icedtea.classpath.org/hg/icedtea-web
cd icedtea-web
./autogen.sh
./configure --with-jdk-home=<path to icedtea6 checkout>/icedtea6/openjdk.build/j2sdk-image --prefix=<path to icedtea6 checkout>/icedtea6/openjdk.build/j2sdk-image

Following that, move /usr/lib/mozilla/plugins/libjavaplugin.so out of that directory, and do an 

ln -s <path to icedtea6 checkout>/icedtea6/openjdk.build/j2sdk-image/jre/lib/i386/IcedTeaPlugin.so .

Either in /usr/lib/mozilla/plugins OR in ~/.mozilla/plugins

Restating firefox after that should make it see the new plugin. You can confirm by typing about:plugins in the address bar and hitting enter. It should show something like:

IcedTea NPR Web Browser Plugin (using IcedTea 1.0pre...)

Comment 11 GoinEasy9 2010-12-06 04:50:45 UTC
Thank you for your response, I will try your instructions above as soon as I return home (I've been on the road).  I'm making this comment to show my appreciation and to let you know I'm not ignoring your work.  Sorry for the delay.

Comment 12 GoinEasy9 2010-12-09 02:57:59 UTC
I had 2 problems compiling:
1) At the end of "make" compiling Icedtea I get the following errors:

make[7]: g++: Command not found
make[7]: *** [../generated/adfiles/adlparse.o] Error 127
make[7]: *** Waiting for unfinished jobs....
make[7]: Leaving directory `/home/GoinEasy9/icedtea6/openjdk.build-ecj/hotspot/outputdir/linux_i486_compiler2/product'
make[6]: *** [ad_stuff] Error 2
make[6]: Leaving directory `/home/GoinEasy9/icedtea6/openjdk.build-ecj/hotspot/outputdir/linux_i486_compiler2/product'
make[5]: *** [product] Error 2
make[5]: Leaving directory `/home/GoinEasy9/icedtea6/openjdk.build-ecj/hotspot/outputdir'
make[4]: *** [generic_build2] Error 2
make[4]: Leaving directory `/home/GoinEasy9/icedtea6/openjdk-ecj/hotspot/make'
make[3]: *** [product] Error 2
make[3]: Leaving directory `/home/GoinEasy9/icedtea6/openjdk-ecj/hotspot/make'
make[2]: *** [hotspot-build] Error 2
make[2]: Leaving directory `/home/GoinEasy9/icedtea6/openjdk-ecj'
make[1]: *** [build_product_image] Error 2
make[1]: Leaving directory `/home/GoinEasy9/icedtea6/openjdk-ecj'
make: *** [stamps/icedtea-ecj.stamp] Error 2

2) During compiling of icedtea-web I'm stopped with:
[root@fedora14dw32 icedtea-web]# checkout>/icedtea6/openjdk.build/j2sdk-image --prefix=</home/GoinEasy9/icedtea6
bash: /icedtea6/openjdk.build/j2sdk-image: No such file or directory

I'm attaching a copy of the build.  I haven't done much compiling, the last time was 2 years ago to get an updated inkscape, so please be kind if I made a dumb mistake.  Thank You.

Comment 13 GoinEasy9 2010-12-09 02:58:57 UTC
Created attachment 467641 [details]
OpenJDK-test-build

Comment 14 Andrew John Hughes 2010-12-09 12:54:10 UTC
I'm confused as to why Deepak asked you to build IcedTea at all.  You should just be able to build IcedTea-Web and install it over your JDK in /usr/lib/jvm/java-1.6.0-openjdk

$ hg clone http://icedtea.classpath.org/hg/icedtea-web
$ cd icedtea-web
$ ./autogen.sh
$ ./configure --prefix=/usr/lib/jvm/java-openjdk
$ make
$ su
<enter root password>
# make install

This will replace the system plugin and NetX with the updated version.  If you then reload Firefox, it will appear in about:plugins as something like:

IcedTea-Web plugin (using IcedTea-Web 1.1pre-+r45c967939b39)

(The final number after -r will vary depending on the latest commit after you checkout the repository).

That should be much simpler.  It just worked a treat on my F14 laptop.

If you do need to revert to the system plugin, just remove and reinstall java-1.6.0-openjdk-plugin.  But the new version should be preferable and will be available as a Fedora package soon.

Comment 15 Deepak Bhole 2010-12-09 14:10:57 UTC
Sorry, for some reason I thought this was F13 (where everything is in rt.jar) :/

Andrew's method of compiling just icedtea-web should be fine for F14.

Comment 16 Andrew John Hughes 2010-12-09 15:03:34 UTC
The F13 version is mentioned in the first comment, so maybe that caused the confusion.

Comment 17 GoinEasy9 2010-12-10 03:33:05 UTC
I apologize for the confusion, all my production machines are running F13, and that's where the problem was first noticed.  The last version to work was the java-1.6.0-openjdk-1:1.6.0.0-37.b17.fc13 from F13.  
Thanks again for your help with this, I will start from scratch and build icedtea-web and report the results to you tomorrow.

Comment 18 GoinEasy9 2010-12-11 01:22:47 UTC
The make failed, last line was:
make: *** [/home/GoinEasy9/icedtea-web/plugin/icedteanp/IcedTeaNPPlugin.o] Error 127
There's an IcedTeaNPPlugin.c and .hh in that folder, but not an .o

If you need a copy of the whole build, let me know.

Comment 19 GoinEasy9 2011-01-22 19:12:49 UTC
A new version of openjdk came in:Jan 20 22:19:40 Updated: 1:java-1.6.0-openjdk-1.6.0.0-50.1.9.4.fc14.i686 and Updated: 1:java-1.6.0-openjdk-plugin-1.6.0.0-50.1.9.4.fc14.i686.
My abilities to find out why I couldn't compile the plugin are limited, so, I waited for the new version.
Unfortunately, results are the same.  I am wondering if the upstream fix was contained in this version.
I haven't had to use Sun/Oracle Java since F11, but it's been 2 months now and without a solution for F14, I am left with using F13 with the older version of OpenJDK on hold.
Please, if there is anything I can contribute to solving this problem, let me know.

Comment 20 Fedora End Of Life 2012-08-16 17:54:15 UTC
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.