Bug 653185 - Finnish keyboard layout problems
Summary: Finnish keyboard layout problems
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Torez Smith
QA Contact: Mike Gahagan
URL:
Whiteboard:
Depends On:
Blocks: 846704
TreeView+ depends on / blocked
 
Reported: 2010-11-14 22:16 UTC by Mika Ilmaranta
Modified: 2016-08-16 05:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-10 13:33:28 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mika Ilmaranta 2010-11-14 22:16:46 UTC
Description of problem:
On a Mac Pro Nehalem keyboard scan codes 86 and 41 produce wrong output as checked with showkey utility.

86 produces "<" and it should produce "§"
41 produces "§" and it should produce "<"

Another problem is with ctrl-alt-functionkey vt changing which doesn't work at all. Ctrl-alt-any function key combination seem all to produce "^@" as output.

I'm not sure if this problem lies with kbd-package as fi.map.gz looks the same as in rhel5.5 which produces correct output from those keys.

Both console and Xorg produce same incorrect output from those keys.

Snippet from /var/log/messages to show keyboard version:
Nov 14 17:36:18 xx kernel: usb 2-3.2: New USB device found, idVendor=05ac, idProduct=0221
Nov 14 17:36:18 xx kernel: usb 2-3.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Nov 14 17:36:18 xx kernel: usb 2-3.2: Product: Apple Keyboard
Nov 14 17:36:18 xx kernel: usb 2-3.2: Manufacturer: Apple, Inc
Nov 14 17:36:18 xx kernel: usb 2-3.2: configuration #1 chosen from 1 choice
Nov 14 17:36:18 xx kernel: input: Apple, Inc Apple Keyboard as /devices/pci0000:00/0000:00:1d.7/usb2/2-3/2-3.2/2-3.2:1.0/input/input4
Nov 14 17:36:18 xx kernel: apple 0003:05AC:0221.0002: input,hidraw1: USB HID v1.11 Keyboard [Apple, Inc Apple Keyboard] on usb-0000:00:1d.7-3.2/input0
Nov 14 17:36:18 xx kernel: input: Apple, Inc Apple Keyboard as /devices/pci0000:00/0000:00:1d.7/usb2/2-3/2-3.2/2-3.2:1.1/input/input5
Nov 14 17:36:18 xx kernel: apple 0003:05AC:0221.0003: input,hidraw2: USB HID v1.11 Device [Apple, Inc Apple Keyboard] on usb-0000:00:1d.7-3.2/input1

Version-Release number of selected component (if applicable):
kbd-1.15-11.el6.x86_64

How reproducible:
Type on the keyboard and wrong output is produced.
Try ctrl-alt-f[1-8] keys and active vt is not changed.

Comment 2 Mika Ilmaranta 2010-11-15 10:39:34 UTC
No problems while using a logitech generic usb keyboard:

Nov 15 12:14:36 xx kernel: usb 8-1: new low speed USB device using uhci_hcd and address 2
Nov 15 12:14:36 xx kernel: usb 8-1: New USB device found, idVendor=046d, idProduct=c310
Nov 15 12:14:36 xx kernel: usb 8-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Nov 15 12:14:36 xx kernel: usb 8-1: Product: USB Multimedia Keyboard
Nov 15 12:14:36 xx kernel: usb 8-1: Manufacturer: BTC
Nov 15 12:14:36 xx kernel: usb 8-1: configuration #1 chosen from 1 choice
Nov 15 12:14:36 xx kernel: input: BTC USB Multimedia Keyboard as /devices/pci0000:00/0000:00:1d.2/usb8/8-1/8-1:1.0/input/input10
Nov 15 12:14:36 xx kernel: generic-usb 0003:046D:C310.0008: input,hidraw3: USB HID v1.10 Keyboard [BTC USB Multimedia Keyboard] on usb-0000:00:1d.2-1/input0
Nov 15 12:14:36 xx kernel: input: BTC USB Multimedia Keyboard as /devices/pci0000:00/0000:00:1d.2/usb8/8-1/8-1:1.1/input/input11
Nov 15 12:14:36 xx kernel: generic-usb 0003:046D:C310.0009: input,hiddev96,hidraw4: USB HID v1.10 Device [BTC USB Multimedia Keyboard] on usb-0000:00:1d.2-1/input1

Comment 3 RHEL Program Management 2011-01-07 15:37:54 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 4 Vitezslav Crhonek 2011-01-11 16:31:42 UTC
[root@norcus ~]# gunzip -c /lib/kbd/keymaps/i386/qwerty/fi.map.gz | grep -E '86|41'
keycode  41 = section
	control keycode  41 = nul
	alt     keycode  41 = Meta_grave
keycode  86 = less             greater          bar
	alt altgr keycode  86 = Meta_bar

According to this, the output from the Description is correct (41 - "§", 86 - "<"). These keycodes are same for RHEL5 and RHEL6.

I looked at Finnish keyboard layout [1] and it seems that keycode 41 should correspond to the key at the left top of the keyboard, keycode 86 should correspond to the key between SHIFT and Z on the left bottom of the keyboard. I assume that these two keys are just switched in the case of Mac Pro Nehalem keyboard, right? If so then there's probably problem within kernel (as there's table which translates scancodes to keycodes).

Can you please compare keycodes obtained from both keyboards? Are these two keys just interchanged?

[1] http://en.wikipedia.org/wiki/File:KB_Finnish_Multilingual.svg

Comment 5 Mika Ilmaranta 2011-01-11 17:53:48 UTC
showkey for "<":

apple kbd:
§keycode  41 press
keycode  41 release

generic kbd:
<keycode  86 press
keycode  86 release


showkey for "§":

apple:
<keycode  86 press
keycode  86 release

generic:
§keycode  41 press
keycode  41 release


showkey for "ctrl+alt+f1":

apple:
keycode  29 press (ctrl)
keycode  56 press (alt)
keycode 224 press
keycode 224 release
keycode  56 release
keycode  29 release

generic:
keycode  29 press
keycode  56 press
keycode  59 press
keycode  59 release
keycode  56 release
keycode  29 release


showkey for "ctrl+alt+f2":

apple:
keycode  29 press
keycode  56 press
keycode 225 press
keycode 225 release
keycode  56 release
keycode  29 release

generic:
keycode  29 press
keycode  56 press
keycode  60 press
keycode  60 release
keycode  56 release
keycode  29 release

This ctrl+alt+f2 was a little tricky because it changed active virtual terminal, hope copied it correctly. All function keys seem to do something else than I expected on an Apple keyboard. But F1 and F2 cases should reveal the pattern in general.

So is this really a problem with the kernel or should there be support in kbd-package for Apple keyboards. Perhaps not and the kernel is to blame?

Comment 6 Vitezslav Crhonek 2011-01-12 09:33:23 UTC
Thanks for information Mika. I believe this should be fixed somewhere in kernel HID drivers, reassigning to the kernel component.

Comment 7 RHEL Program Management 2011-02-01 05:32:03 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 8 RHEL Program Management 2011-02-01 18:51:59 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 9 RHEL Program Management 2011-04-04 02:18:40 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 10 RHEL Program Management 2011-10-07 15:17:57 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 11 Torez Smith 2016-08-09 19:15:59 UTC
Hi Mike,
some how this BZ just landed in my Q and before I proceed further, I'd like to ask if this is still a problem?

I am noticing this was opened over 6 years back and many, many, many things have changed since then.

Are you running with the latest RHEL6, and if so, are you still seeing this problem?

If so, I'd need more information to recreate and/or debug.

thanks in advance!!

Comment 12 Mika Ilmaranta 2016-08-10 06:19:20 UTC
I changed to OS X and Parallels so I can't tell if this is still a problem.

BR,
Mika


(In reply to Torez Smith from comment #11)
> Hi Mike,
> some how this BZ just landed in my Q and before I proceed further, I'd like
> to ask if this is still a problem?
> 
> I am noticing this was opened over 6 years back and many, many, many things
> have changed since then.
> 
> Are you running with the latest RHEL6, and if so, are you still seeing this
> problem?
> 
> If so, I'd need more information to recreate and/or debug.
> 
> thanks in advance!!

Comment 14 Torez Smith 2016-08-10 13:33:28 UTC
(In reply to Mika Ilmaranta from comment #12)
> I changed to OS X and Parallels so I can't tell if this is still a problem.
> 
> BR,
> Mika
> 
> 
> (In reply to Torez Smith from comment #11)
> > Hi Mike,
> > some how this BZ just landed in my Q and before I proceed further, I'd like
> > to ask if this is still a problem?
> > 
> > I am noticing this was opened over 6 years back and many, many, many things
> > have changed since then.
> > 
> > Are you running with the latest RHEL6, and if so, are you still seeing this
> > problem?
> > 
> > If so, I'd need more information to recreate and/or debug.
> > 
> > thanks in advance!!

ok, thank you very much for your response!!


Note You need to log in before you can comment on or make changes to this bug.