Bug 653195 - SELinux is preventing /usr/libexec/gdm-session-worker "remove_name" access on .xsession-errors.
Summary: SELinux is preventing /usr/libexec/gdm-session-worker "remove_name" access ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:e096897c92b...
: 653196 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-14 23:56 UTC by Juergen Kaiserling
Modified: 2011-05-25 20:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-25 20:48:14 UTC
Type: ---


Attachments (Terms of Use)

Description Juergen Kaiserling 2010-11-14 23:56:15 UTC
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "remove_name" access on
.xsession-errors.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:samba_share_t:s0
Target Objects                .xsession-errors [ dir ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.30.2-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-69.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.34.7-61.fc13.i686.PAE #1 SMP Tue
                              Oct 19 04:24:06 UTC 2010 i686 i686
Alert Count                   8
First Seen                    Tue 09 Nov 2010 10:02:00 PM EST
Last Seen                     Sun 14 Nov 2010 06:55:11 PM EST
Local ID                      6c1ba834-a1fc-4a13-b83e-978097522931
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1289778911.881:25620): avc:  denied  { remove_name } for  pid=2803 comm="gdm-session-wor" name=".xsession-errors" dev=sda3 ino=1572969 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:samba_share_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1289778911.881:25620): avc:  denied  { add_name } for  pid=2803 comm="gdm-session-wor" name=".xsession-errors.old" dev=sda3 ino=1572874 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:samba_share_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1289778911.881:25620): arch=40000003 syscall=38 success=yes exit=0 a0=846fd08 a1=846fd40 a2=846fd40 a3=846fd08 items=0 ppid=2782 pid=2803 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=4 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm-session-wor,xdm_t,samba_share_t,dir,remove_name
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t samba_share_t:dir { remove_name add_name };

Comment 1 Miroslav Grepl 2010-11-15 09:24:28 UTC
*** Bug 653196 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2010-11-15 09:30:29 UTC
.xsession-errors is mislabeled. 

# restorecon -R -v ~/.xsession-errors

will fix it. But did you setup "samba_share_t" label in your home directory?

Comment 3 Daniel Walsh 2010-11-15 16:00:52 UTC
If you want to share your homedir via samba you should use

setsebool -P use_samba_home_dirs 1

Do not label the homedir samba_share_t.


Note You need to log in before you can comment on or make changes to this bug.