Bug 65320 - Kernel 2.4.18-3-SMP Locks on boot
Kernel 2.4.18-3-SMP Locks on boot
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-21 18:37 EDT by Jason P Whipp
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 15:27:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason P Whipp 2002-05-21 18:37:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
Kernel locks on boot w/ EPoX DV3A Motherboard w/ Dual PIII 667s.  Gets to PTY: 
Unix98 ptys ... or I get bad EIP value kernel panic: attempted to kill the idle 
task! Then locks. This happens regardless of which MPS is being used (1.1 or 
1.4) also happens whether APM is on or off.  Note that the 2.4.7-10Enterprise 
kernel will boot most of the time in MPS 1.1 mode.

Version-Release number of selected component (if applicable):
Kernel 2.4.18-3-SMP

How reproducible:
Always

Steps to Reproduce:
1. Boot the SMP Kernel in Red Hat 7.3 on a motherboard of same type
2.
3.
	

Expected Results:  The kernel should boot.

Additional info:

Video Card: Riva TNT2 Ultra
CPUs: two Intel P3 667s
Motherboard: EPoX EP-D3VA
Raid Controler: HighPoint 370 ATA100 Raid Controler
Hard Drive: Maxtor 7200 RPM  ATA100  20 Gig

Carefully researched and tried every related suggestion on www.linuxdoc.org to 
no avail.
Comment 1 Arjan van de Ven 2002-05-22 07:37:07 EDT
if it's the same EIP every time, could you try to see which function that is?
(The kernel will print that with the addresses)
Comment 2 Need Real Name 2002-07-29 12:10:45 EDT
have you try the kernel 2.4-18-5SMP?
Comment 3 Scott 2002-12-05 10:54:44 EST
I have a similar issue with 3 other Red Hat servers.  (v 7.1 and 7.3)  When 
using the 2.4.18-? kernels the system locks on boot everytime.  I can go back 
on the version (2.4.9-34 or earlier) and the boot is fine.

One server is an Intel 440gx server platform which needs the SMP kernel to 
work.  The other two are MSI and gigabyte with AMD processors and I'm not 
using the SMP kernel.

It looks like the one common thread is that they all have some type of raid 
controller.  My systems all run off of SCSI RAID, I believe AMI controllers.

What kind of information can I get for you off of these systems?  This bug 
sounds like the same issue I'm having.
Comment 4 Jason P Whipp 2002-12-07 10:51:51 EST
Sorry I haven't updated this bug.  Apparently, all Red Hat kernels will lock if 
this device is attached to the USB port:
SanDisk ImageMate USB (SDDR 31)
Anytime this device is plugged in, the kernel will lock, otherwise it boots 
fine. All versions of the SMP kernels I've used act the same.  I now boot the 
UP kernel to use the ImageMate.
Comment 5 Pete Zaitcev 2002-12-07 13:27:18 EST
Is it possible to connect serial console to the box which breaks?
That EIP value is important (and the rest of the trace).
Comment 6 Jason P Whipp 2002-12-07 16:44:32 EST
Serial console? You'll have to explain that to me. A kernel panic does not 
always occur, mostly the kernel stops at "UNIX 98 PTYS Configured".  The SMP 
kernel in Red Hat 8.0 has only done that, actually. I haven't and EIP value to 
send.
Comment 7 Scott 2002-12-08 23:19:26 EST
I don't have anything like that hooked up to mine.  All (3) of the computers 
are servers off the Internet.

One of the servers that has a problem also stops at the "UNIX 98 PTYS 
Configured", I'm not sure on the other two since I had to get them up right 
after the boot.  I'd need to schedule down time for those.

I don't have USB devices, but there may be a controller that I'm not aware of.
Comment 8 Pete Zaitcev 2003-10-06 19:19:14 EDT
How is 2.4.20-20.7 doing?

Note You need to log in before you can comment on or make changes to this bug.