Bug 653204 - [abrt] meld-1.3.2-1.fc14: _vc.py:41:Entry:AssertionError
Summary: [abrt] meld-1.3.2-1.fc14: _vc.py:41:Entry:AssertionError
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: meld
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:87ed4696
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-15 00:53 UTC by xuhuashan@gmail.com
Modified: 2011-05-10 21:21 UTC (History)
7 users (show)

Fixed In Version: meld-1.5.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-10 21:21:32 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.20 KB, text/plain)
2010-11-15 00:53 UTC, xuhuashan@gmail.com
no flags Details
Fixes the error in zh_CN translation. (530 bytes, patch)
2010-11-29 02:26 UTC, Peng Wu
no flags Details | Diff

Description xuhuashan@gmail.com 2010-11-15 00:53:23 UTC
abrt version: 1.1.13
architecture: i686
cmdline: python /usr/bin/meld
component: meld
executable: /usr/bin/meld
kernel: 2.6.35.6-48.fc14.i686
package: meld-1.3.2-1.fc14
reason: _vc.py:41:Entry:AssertionError
release: Fedora release 14 (Laughlin)
How to reproduce: just open meld.
time: 1289782272
uid: 500

backtrace
-----
_vc.py:41:Entry:AssertionError

Traceback (most recent call last):
  File "/usr/bin/meld", line 123, in <module>
    main()
  File "/usr/bin/meld", line 114, in main
    import meld.meldapp
  File "/usr/share/meld/meld/meldapp.py", line 42, in <module>
    import vcview
  File "/usr/share/meld/meld/vcview.py", line 23, in <module>
    import tree
  File "/usr/share/meld/meld/tree.py", line 25, in <module>
    from vc._vc import STATE_IGNORED, STATE_NONE, STATE_NORMAL, STATE_NOCHANGE, \
  File "/usr/share/meld/meld/vc/__init__.py", line 26, in <module>
    import _null
  File "/usr/share/meld/meld/vc/_null.py", line 24, in <module>
    import _vc
  File "/usr/share/meld/meld/vc/_vc.py", line 38, in <module>
    class Entry(object):
  File "/usr/share/meld/meld/vc/_vc.py", line 41, in Entry
    assert len(states)==STATE_MAX
AssertionError

Local variables in innermost frame:
states: ['\xe5\xbf\xbd\xe7\x95\xa5\xef\xbc\x9a\xe7\x89\x88\xe6\x9c\xac\xe4\xb8\x8d\xe8\xaf\xa6', '', '', '\xe9\x94\x99\xe8\xaf\xaf', '', '\xe6\x96\xb0\xe6\xb7\xbb\xe5\x8a\xa0', '\xe5\xb7\xb2\xe4\xbf\xae\xe6\x94\xb9', '<b>\xe5\x86\xb2\xe7\xaa\x81</b>', '\xe5\xb7\xb2\xe5\x88\xa0\xe9\x99\xa4', '\xe4\xb8\xa2\xe5\xa4\xb1']
__module__: 'meld.vc._vc'

Comment 1 xuhuashan@gmail.com 2010-11-15 00:53:25 UTC
Created attachment 460442 [details]
File: backtrace

Comment 2 cnangel 2010-11-19 02:36:57 UTC
Package: meld-1.3.2-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.open the meld just
2.
3.

Comment 3 xuhuashan@gmail.com 2010-11-20 03:16:47 UTC
this only happen in chinese zh_CN locale,when i start meld in then en_US locale, this issue will not reproduce.

Comment 4 cnangel 2010-11-25 12:42:00 UTC
Package: meld-1.3.2-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.中文操作系统,启动fedora的时候发生core
2.
3.

Comment 5 Peng Wu 2010-11-29 02:26:08 UTC
Created attachment 463408 [details]
Fixes the error in zh_CN translation.

This seems a bug in zh_CN translation, in zh_CN.po.
It should use ":" instead of ":".
Please review this patch.

Comment 6 Peng Wu 2010-12-01 02:02:56 UTC
This bug can be re-produced on English locale,
with the following command:
$ LANG=zh_CN.UTF-8 LC_ALL=zh_CN.UTF-8 meld 
Traceback (most recent call last):
  File "/usr/bin/meld", line 123, in <module>
    main()
  File "/usr/bin/meld", line 114, in main
    import meld.meldapp
  File "/usr/share/meld/meld/meldapp.py", line 42, in <module>
    import vcview
  File "/usr/share/meld/meld/vcview.py", line 23, in <module>
    import tree
  File "/usr/share/meld/meld/tree.py", line 25, in <module>
    from vc._vc import STATE_IGNORED, STATE_NONE, STATE_NORMAL, STATE_NOCHANGE, \
  File "/usr/share/meld/meld/vc/__init__.py", line 26, in <module>
    import _null
  File "/usr/share/meld/meld/vc/_null.py", line 24, in <module>
    import _vc
  File "/usr/share/meld/meld/vc/_vc.py", line 38, in <module>
    class Entry(object):
  File "/usr/share/meld/meld/vc/_vc.py", line 41, in Entry
    assert len(states)==STATE_MAX
AssertionError

Comment 7 cnangel 2010-12-16 06:13:47 UTC
Package: meld-1.3.2-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
[cnangel@localhost ~]$locale
LANG=zh_CN.UTF-8
LC_CTYPE="zh_CN.UTF-8"
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=zh_CN.UTF-8

[cnangel@localhost ~]$meld
Traceback (most recent call last):
  File "/usr/bin/meld", line 123, in <module>
    main()
  File "/usr/bin/meld", line 114, in main
    import meld.meldapp
  File "/usr/share/meld/meld/meldapp.py", line 42, in <module>
    import vcview
  File "/usr/share/meld/meld/vcview.py", line 23, in <module>
    import tree
  File "/usr/share/meld/meld/tree.py", line 25, in <module>
    from vc._vc import STATE_IGNORED, STATE_NONE, STATE_NORMAL, STATE_NOCHANGE, \
  File "/usr/share/meld/meld/vc/__init__.py", line 26, in <module>
    import _null
  File "/usr/share/meld/meld/vc/_null.py", line 24, in <module>
    import _vc
  File "/usr/share/meld/meld/vc/_vc.py", line 38, in <module>
    class Entry(object):
  File "/usr/share/meld/meld/vc/_vc.py", line 41, in Entry
    assert len(states)==STATE_MAX

Comment 8 Haifeng.qianhf 2011-01-15 04:33:14 UTC
Package: meld-1.3.2-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.start
2.
3.

Comment 9 Mike Ma 2011-01-22 04:11:31 UTC
Package: meld-1.3.2-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.忘了. . . 
2.
3.

Comment 10 cnangel 2011-02-12 07:15:47 UTC
Package: meld-1.3.2-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.run meld
2.
3.

Comment 11 ebird98 2011-02-14 05:22:59 UTC
Package: meld-1.3.2-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.type 'meld' in command line.
2.
3.
meld crashed.

Comment
-----
python.i686                            2.7-8.fc14.1
kernel-PAE.i686                    2.6.35.11-83.fc14

Comment 12 Fedora Admin XMLRPC Client 2011-03-13 15:38:48 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 13 Dominic Hopf 2011-03-13 17:49:58 UTC
(In reply to comment #6)
> This bug can be re-produced on English locale,
> with the following command:
> $ LANG=zh_CN.UTF-8 LC_ALL=zh_CN.UTF-8 meld 

This command changes the locale from english to chinese, doesn't it?

Comment 14 Peng Wu 2011-03-14 02:38:07 UTC
(In reply to comment #13)
> (In reply to comment #6)
> > This bug can be re-produced on English locale,
> > with the following command:
> > $ LANG=zh_CN.UTF-8 LC_ALL=zh_CN.UTF-8 meld 
> 
> This command changes the locale from english to chinese, doesn't it?


Yes, it is Simplified Chinese. and I think it is an error in translation.
Please see the above patch.

Comment 15 Mike Ma 2011-04-04 02:14:37 UTC
Package: meld-1.3.2-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Just start it
2.
3.

Comment 16 Dominic Hopf 2011-04-17 18:10:44 UTC
I have to admit I had no chance to review your patch yet, unfortunately. Anyway, maybe you like to check out first if the issue is still present with the new meld 1.5.1. A package can be downloaded here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3007032

Comment 17 Peng Wu 2011-04-18 02:21:12 UTC
It seems fixed in meld-1.5.1-1.fc14.noarch.rpm.

Comment 18 Fedora Update System 2011-05-01 11:28:23 UTC
meld-1.5.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/meld-1.5.1-1.fc14

Comment 19 Fedora Update System 2011-05-01 20:54:44 UTC
Package meld-1.5.1-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing meld-1.5.1-1.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/meld-1.5.1-1.fc14
then log in and leave karma (feedback).

Comment 20 Fedora Update System 2011-05-10 21:21:13 UTC
meld-1.5.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.