Bug 653260 - Guest kernel panic with spice cause host CapsLock and NumLock on and off in a loop
Guest kernel panic with spice cause host CapsLock and NumLock on and off in ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: qspice-client (Show other bugs)
5.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Blechter
SPICE QE bug list
: Triaged
Depends On: 630825
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-11-15 00:09 EST by Shirley Zhou
Modified: 2015-08-24 08:09 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 630825
Environment:
Last Closed: 2015-08-24 08:09:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shirley Zhou 2010-11-15 00:09:52 EST
This issue also exist on RHEL5.6.

kvm-83-207.el5
# uname -r
2.6.18-230.el5
+++ This bug was initially created as a clone of Bug #630825 +++

Description of problem:


Version-Release number of selected component (if applicable):
host :RHEL6.0 RC
# uname -r
2.6.32-71.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.113.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.start VM with -spice 
eg:/usr/libexec/qemu-kvm -M rhel6.0.0 -enable-kvm -m 2048 -smp 2 -name rhel5_ide_64_1 -uuid bdcbfb49-3411-1701-3c36-6bdbc00bedb9 -rtc base=utc,clock=host,driftfix=slew -boot dc -drive file=/home/ide/rhel5u5_64_ide_1.qcow2,if=none,id=drive-ide0-0-0,boot=on,format=qcow2 -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:10:f4:c2:c4,bus=pci.0,addr=0x3 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -device usb-tablet,id=input0 -spice port=5910,disable-ticketing -vga qxl -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6 -monitor stdio -qmp tcp:0:4441,server,nowait
2.connect the guest by using #/usr/libexec/spicec -h localhost -p port
3.make guest kernel panic ,eg :# echo "cā€œ > /proc/sysrq-rigger

  
Actual results:
NumLock and CapsLock are on and off in a loop ,the LED for NumLock and CapsLock in the keyboard twinkled.


Expected results:


Additional info:
start vm with -vnc will not hit the issue.
Comment 2 RHEL Product and Program Management 2011-01-11 16:15:56 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-01-11 17:56:02 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 4 Eduardo Habkost 2011-01-17 06:48:48 EST
Bug is on the client, as the leds are supposed to blink, but not when the client doesn't have focus.
Comment 7 Alon Levy 2011-03-21 11:40:34 EDT
I have a scratch build, can you see if it solves the problem (tested locally with the patches in the build):

 https://brewweb.devel.redhat.com/taskinfo?taskID=3190375

Thanks,
Alon
Comment 8 Alon Levy 2011-04-13 01:35:42 EDT
Can someone test the scratch build above?
Comment 9 Suqin Huang 2011-04-13 02:05:40 EDT
Hi Alon, I can not download the package
Comment 10 Lubos Kocman 2011-05-09 09:53:16 EDT
Hello Alon,

the scratch build is gone. Could you please create some non-temporary build with backported fix from RHEL6? So we can finally fix it? 

Set back to assigned as there is no avaiable build with the fix.
Comment 11 Alon Levy 2011-05-11 14:51:52 EDT
https://brewweb.devel.redhat.com/taskinfo?taskID=3317048

Sorry for the delay, had to relearn the building procedure.
Comment 12 Mike Cao 2011-05-11 22:50:30 EDT
(In reply to comment #11)
> https://brewweb.devel.redhat.com/taskinfo?taskID=3317048
> 
> Sorry for the delay, had to relearn the building procedure.

Tried qspice-client-0.3.0-5.alon.1.el5.x86_64.rpm  ,still can reproduce .

Best Regards,
Mike
Comment 17 David Blechter 2015-08-24 08:09:22 EDT
closing, qspice-client is not supported

Note You need to log in before you can comment on or make changes to this bug.