Bug 653263 - spice can not be connected during live migration in progress.
spice can not be connected during live migration in progress.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-11-15 00:35 EST by Mike Cao
Modified: 2015-11-22 22:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-12 05:53:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2010-11-15 00:35:53 EST
Description of problem:
when live migration begins ,the vm in src host still running ,but spice-client quit.and can only reconnect it after exec migraion_cancel or migration compeleted.

Version-Release number of selected component (if applicable):
# uname -r 
2.6.18-230.el5
# rpm -q kvm
kvm-83-207.el5


How reproducible:
100%

Steps to Reproduce:
1.start VM with -spice in src host:
CLI: /usr/libexec/qemu-kvm -no-hpet -no-kvm-pit-reinjection -usbdevice tablet -rtc-td-hack -startdate now -name win08R2 -smp 4 -m 8G -boot dc -net nic,vlan=0,macaddr=12:23:32:12:13:18,model=virtio -net tap,vlan=0,script=/etc/qemu-ifup -drive file=/dev/mike/win08R2,media=disk,if=virtio,cache=none,boot=on,format=raw,werror=stop -spice host=0,ic=on,port=5910,disable-ticketing -qxl 1 -cpu qemu64 -M rhel5.6.0 -notify all -balloon virtio -monitor stdio -uuid 4e8567a1-4f9a-40aa-89d4-6278dd6c26d5
2.start listenning port
3.do live migration
  
Actual results:
spice client quit and can not re-connect to the VM during live migration in progress.

Expected results:
spice client should still connect to the VM for user's operation during live migration in progress.


Additional info:
Comment 2 RHEL Product and Program Management 2011-01-11 16:15:51 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-01-11 17:56:09 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 4 Gerd Hoffmann 2011-01-12 05:53:25 EST
Spice server does this intentionally, seems to be needed for the spice client migration (i.e. have the spice client switch over to the new host after migration automatically).  Changing this looks non-trivial and has a pretty high risk of introducing regressions.

Note You need to log in before you can comment on or make changes to this bug.