Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 653302 - w3m-load.el not included in emacs-w3m subpackage
Summary: w3m-load.el not included in emacs-w3m subpackage
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs-common-w3m
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-15 08:41 UTC by Michel Alexandre Salim
Modified: 2010-11-15 08:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-15 08:42:59 UTC
Type: ---


Attachments (Terms of Use)

Description Michel Alexandre Salim 2010-11-15 08:41:08 UTC
Description of problem:
w3m-load.el is an initialization file that never gets byte-compiled; it is expected by, e.g., pure's Emacs mode to be available.

Version-Release number of selected component (if applicable):
emacs-common-w3m-1.4.398-0.3.20100714cvs.fc14

How reproducible:
Always

Steps to Reproduce:
1. Install emacs-w3m
2. Install emacs-pure >= 0.45-3
3. Open a .pure file, C-c C-h on some Pure identifier (e.g. double)
  
Actual results:
The system browser is fired up, not w3m; also, since Pure only integrates properly with w3m, the entire help is displayed, not just the requested topic

Expected results:
Emacs switches to w3m buffer showing the requested topic; leaving this returns back to the Pure file

Additional info:


Note You need to log in before you can comment on or make changes to this bug.