Bug 65333 - CUPS cannot find SMB backend.
Summary: CUPS cannot find SMB backend.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cups   
(Show other bugs)
Version: 7.3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-22 10:05 UTC by David Woodhouse
Modified: 2007-04-18 16:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 19:21:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 2002-05-22 10:05:14 UTC
CUPS cannot print to SMB printers until you manually make a symlink from
/usr/lib/cups/backend/smb to /usr/bin/smbspool.

If smbspool is there for the sole purpose of being a CUPS backend, then perhaps
it should be split into a separate binary package and put in /usr/lib/cups/backend?

Otherwise, perhaps we need to play with triggers to make the symlink or
something similar.

Comment 1 Trond Eivind Glomsrxd 2002-05-22 16:24:23 UTC
Sounds like a cups issue.

Comment 2 Bernhard Rosenkraenzer 2002-05-22 16:30:25 UTC
The cups spec file has: 
 
%triggerin -- samba-clients 
ln -sf ../../../bin/smbspool %{_libdir}/cups/backend/smb || : 
exit 0 
 
%triggerun -- samba-clients 
[ $2 = 0 ] || exit 0 
rm -f %{_libdir}/cups/backend/smb 
 
 
Did you install samba-clients? 


Comment 3 David Woodhouse 2002-05-22 17:17:45 UTC
samba-client is installed.
samba-clients is not.

If that was just a typo... yes, samba-client was installed before the upgrade to
7.3, cups was installed later.

Comment 4 Tim Waugh 2002-09-26 07:22:04 UTC
This has been fixed since cups-1.1.15-1.


Note You need to log in before you can comment on or make changes to this bug.