Bug 65335 - ps2pdf 6.53 fails to convert where 5.50 worked fine
ps2pdf 6.53 fails to convert where 5.50 worked fine
Status: CLOSED DUPLICATE of bug 74633
Product: Red Hat Linux
Classification: Retired
Component: ghostscript (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-22 06:28 EDT by Pekka Savola
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-14 12:01:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2002-05-22 06:28:32 EDT
This seems a bit similar, yet different, to the two previous ps2pdf reports.

After upgrading from RHL72 to RHL73, ps2pdf fails to convert a file properly
that worked just fine before:

$ ps2pdf dsr.ps

Error: /rangecheck in --get--
Operand stack:
   --nostringval--   --nostringval--   --nostringval--   descender   0  
--nostringval--   1
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3  
%oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--  
--nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1038/1476(ro)(G)--   --dict:0/20(G)--   --dict:86/200(L)--  
--dict:122/300(L)--   --dict:49/200(L)--   --dict:37/52(L)--  
--dict:1/17(L)--   --dict:5/17(L)--   --dict:1/3(L)--   --dict:13/14(ro)(L)--
Current allocation mode is local
Current file position is 95746
GNU Ghostscript 6.53: Unrecoverable error, exit code 1

(First 4 of 10 pages are created just fine, it seems.)

$ rpm -q ghostscript
ghostscript-6.53-4

The postscript is available at:

http://staff.csc.fi/psavola/adhoc/dsr.ps
Comment 1 Tim Waugh 2002-05-22 06:38:18 EDT
6.53-4 was not shipped in 7.3; 6.52-8 was.  Does that also show the problem?
Comment 2 Pekka Savola 2002-05-22 06:44:08 EDT
Sorry, must have been from a beta.

6.52-8 does also show the problem.
Comment 3 Tim Waugh 2002-05-22 06:56:17 EDT
FWIW, 7.05-3 (from rawhide) also does the same thing.
Comment 4 John Heidemann 2002-06-11 09:09:05 EDT
I have the same error, and possibly a smaller reproducable test case.

The file at http://www.isi.edu/~johnh/PUBLIC/idraw.ps was generated by idraw. 
It worked fine in RH 7.2 and won't ghostview or ps2pdf or even gs in RH 7.3.
It has the same error as above with RH7.3.

What's strange is that revering the ghostscript version does not help.
I tried installing these RPMs on my 7.3 system, but all had the same error:

ghostscript-6.51-12.i386.rpm
ghostscript-6.51-16.2.i386.rpm
ghostscript-6.52-8.i386.rpm
ghostscript-6.52-9.4.i386.rpm

(i.e., the basic and patched versions in RH 7.2 and 7.3).
Comment 5 Alex Cherepanov 2002-10-14 11:53:39 EDT
This is a duplicate of bug #74633.

The sample file is incorrect. It assumes that FontBBox is an
executable array. Although many fonts are designed this way
there is no such requiriment in the spec. Probably, different RH
versions install different fonts. The file should be
changed to work with both executable and literal
arrays.

Comment 6 Pekka Savola 2002-10-14 11:59:49 EDT
In that case, either xfig (probable) or latex is generating incorrect postscript.
Comment 7 Pekka Savola 2002-10-14 12:00:59 EDT
Hmm.. or maybe not: I recall I copied some pics from other sources, I don't know how those were generated.
Comment 8 Tim Waugh 2002-10-14 16:16:36 EDT
If you can reproduce it without those, please re-open. 

*** This bug has been marked as a duplicate of 74633 ***

Note You need to log in before you can comment on or make changes to this bug.