Bug 653353 - [RV570] r300g unusable slow with trackballs
Summary: [RV570] r300g unusable slow with trackballs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-15 09:54 UTC by Hans de Goede
Modified: 2018-04-11 08:47 UTC (History)
2 users (show)

Fixed In Version: mesa-7.9-4.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-18 15:57:05 UTC


Attachments (Terms of Use)
xorg.log (160.19 KB, text/plain)
2010-11-15 09:54 UTC, Hans de Goede
no flags Details

Description Hans de Goede 2010-11-15 09:54:53 UTC
Created attachment 460510 [details]
xorg.log

Steps to Reproduce:
1. yum install trackballs
2. trackballs
3. play
  
Actual results:
2-3 fps


Expected results:
usable fps

Additional info:
* This works fine when I downgrade mesa to 7.8 from F-13
* The terminal from which trackballs is started fills with:
  r300 VP: cannot handle edgeflag output.
* lspci:
00:0e.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0f.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
03:00.0 VGA compatible controller: ATI Technologies Inc RV570 [Radeon X1950 Pro] (rev 9a)
03:00.1 Display controller: ATI Technologies Inc RV570 [Radeon X1950 Pro] (secondary) (rev 9a)
* dmesg does not contain anything interesting

Comment 1 Hans de Goede 2010-11-15 09:58:48 UTC
Still happens with 7.10-0.10.fc15 .

Comment 2 Dave Airlie 2010-12-05 06:47:23 UTC
proposed fix on upstream mailing list

will resnapshot when it lands.

http://lists.freedesktop.org/archives/mesa-dev/2010-December/004367.html

Comment 3 Dave Airlie 2010-12-07 02:29:12 UTC
should be fixed in F14 in latest update, haven't rebased rawhide yet.

https://admin.fedoraproject.org/updates/mesa-7.9-4.fc14

but since this bug is against f14.

Comment 4 Hans de Goede 2010-12-07 09:53:05 UTC
I can confirm that mesa-7.9-4.fc14 fixes this, thanks.

Comment 5 Matěj Cepl 2011-03-18 15:57:05 UTC
Thank you for letting us know.


Note You need to log in before you can comment on or make changes to this bug.