Bug 65337 - Qt-OpenGL app. segfaults in QGLWidget constructor
Qt-OpenGL app. segfaults in QGLWidget constructor
Status: CLOSED DUPLICATE of bug 65338
Product: Red Hat Linux
Classification: Retired
Component: qt (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-22 08:56 EDT by Nicolas Aspert
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-22 08:56:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Aspert 2002-05-22 08:56:43 EDT
Description of Problem:
An Qt-OpenGL app crashes (segfault) inside the constructor of a QGLWidget. The
same app runs smoothly on RH-7.2 (Qt 2.3 and 3.0.3), whereas it is not possible
to run it correctly on RH-7.3 (with both Qt-2.3.1 and Qt-3.0.3)

Version-Release number of selected component (if applicable):


How Reproducible:
Easily (cf. below)

Steps to Reproduce:
1. Build the 'Mesh' app. (see attachment)
2. In the top directory of Mesh, issue the following command :
./bin/mesh venus3_s.wrl venus3.smf
3. D'oh !

Actual Results:
Segfault. (Inside QGLWidget constructor)

Expected Results:
Nice visualization window. 

Additional Information:
The program runs correctly with a freshly-built Qt-3.0.4 (except for a segfault
when quitting, which may be my fault)	
The problem might be related to the use of a NVidia ^&* closed-source driver.
Comment 1 Bernhard Rosenkraenzer 2002-05-22 09:08:18 EDT

*** This bug has been marked as a duplicate of 65338 ***

Note You need to log in before you can comment on or make changes to this bug.