Bug 653399 - SELinux is preventing /usr/sbin/sendmail.sendmail "read" access on /var/spool/clientmqueue.
Summary: SELinux is preventing /usr/sbin/sendmail.sendmail "read" access on /var/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:d9afed9c2c3...
: 653400 653401 653402 653403 653404 653405 653406 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-15 11:00 UTC by pigetak178
Modified: 2011-05-27 14:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-27 14:14:23 UTC
Type: ---


Attachments (Terms of Use)

Description pigetak178 2010-11-15 11:00:36 UTC
Summary:

SELinux is preventing /usr/sbin/sendmail.sendmail "read" access on
/var/spool/clientmqueue.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by sendmail. It is not expected that this access
is required by sendmail and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:ddclient_t:s0
Target Context                system_u:object_r:mqueue_spool_t:s0
Target Objects                /var/spool/clientmqueue [ dir ]
Source                        sendmail
Source Path                   /usr/sbin/sendmail.sendmail
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           sendmail-8.14.4-9.fc14
Target RPM Packages           sendmail-8.14.4-9.fc14
Policy RPM                    selinux-policy-3.9.7-10.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.35.6-48.fc14.x86_64 #1 SMP Fri Oct 22 15:36:08
                              UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Mon 15 Nov 2010 04:08:06 AM EST
Last Seen                     Mon 15 Nov 2010 04:08:06 AM EST
Local ID                      fd39febc-6bc7-4e58-ba6f-3b2fc5031406
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1289812086.191:421): avc:  denied  { read } for  pid=15177 comm="sendmail" name="clientmqueue" dev=dm-0 ino=137223 scontext=system_u:system_r:ddclient_t:s0 tcontext=system_u:object_r:mqueue_spool_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1289812086.191:421): avc:  denied  { open } for  pid=15177 comm="sendmail" name="clientmqueue" dev=dm-0 ino=137223 scontext=system_u:system_r:ddclient_t:s0 tcontext=system_u:object_r:mqueue_spool_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1289812086.191:421): arch=c000003e syscall=2 success=yes exit=4 a0=7fff4a48c370 a1=0 a2=1c0 a3=7fff4a48d120 items=0 ppid=3268 pid=15177 auid=4294967295 uid=496 gid=493 euid=496 suid=496 fsuid=496 egid=51 sgid=51 fsgid=51 tty=(none) ses=4294967295 comm="sendmail" exe="/usr/sbin/sendmail.sendmail" subj=system_u:system_r:ddclient_t:s0 key=(null)



Hash String generated from  catchall,sendmail,ddclient_t,mqueue_spool_t,dir,read
audit2allow suggests:

#============= ddclient_t ==============
allow ddclient_t mqueue_spool_t:dir { read open };

Comment 1 Miroslav Grepl 2010-11-15 11:06:51 UTC
*** Bug 653400 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2010-11-15 11:07:17 UTC
*** Bug 653401 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2010-11-15 11:07:42 UTC
*** Bug 653402 has been marked as a duplicate of this bug. ***

Comment 4 Miroslav Grepl 2010-11-15 11:08:32 UTC
*** Bug 653403 has been marked as a duplicate of this bug. ***

Comment 5 Miroslav Grepl 2010-11-15 11:08:59 UTC
*** Bug 653404 has been marked as a duplicate of this bug. ***

Comment 6 Miroslav Grepl 2010-11-15 11:09:21 UTC
*** Bug 653405 has been marked as a duplicate of this bug. ***

Comment 7 Miroslav Grepl 2010-11-15 11:12:03 UTC
*** Bug 653406 has been marked as a duplicate of this bug. ***

Comment 8 Miroslav Grepl 2010-11-15 11:12:45 UTC
Fixed in selinux-policy-3.9.7-13.fc14


Note You need to log in before you can comment on or make changes to this bug.