Bug 65349 - mouse-avoidance-fancy-hook needs guarding
mouse-avoidance-fancy-hook needs guarding
Status: CLOSED DUPLICATE of bug 65346
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2002-05-22 11:23 EDT by Reuben Thomas
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-22 11:23:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Reuben Thomas 2002-05-22 11:23:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461; Q312461)

Description of problem:
[This is, IMO, an upstream bug, which I've reported a couple of times to the 
upstream maintainers, without any luck.]

If I use mouse-avoidance-fancy-hook in my post-command-hook, I sometimes get 
errors causing post-command-hook to be set to nil (most annoying). I think this 
is really due to a bug in mouse-avoidance-fancy-hook, but can't be bothered to 
dig it out, since it seems to cause no ill effects (and mouse-avoidance is 
purely a cosmetic thing).

I do have a fix: simply wrap mouse-avoidance-fancy-hook's body in(condition-
case nil ... (error nil)), i.e. ignore any errors generated inside it. I've 
been using this fix for months with no ill effects.

mouse-avoidance-fancy-hook is in xemacs-packages/lisp/edit-utils/avoid.el.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actually reproducing the bug in normal use is tricky. Try something like:

1. Add mouse-avoidance-fancy-hook to your post-command-hook
2. Use XEmacs a lot, closing buffers from time to time (C-x k)
3. Eventually, you should get an error, caused by a position being out of 
range. I think it's because mouse-avoidance-fancy-hook is trying to examine 
part of a buffer that has just been killed. This will set post-command-hook to 

Actual Results:  post-command-hook was set to nil and I got an error

Expected Results:  Neither: it should Just Work (TM)

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-05-22 12:16:20 EDT

*** This bug has been marked as a duplicate of 65346 ***

Note You need to log in before you can comment on or make changes to this bug.