Bug 653523 - Inconsistency detected by ld.so: dl-close.c: _dl_close: Assertion `map->l_init_called' failed!
Summary: Inconsistency detected by ld.so: dl-close.c: _dl_close: Assertion `map->l_ini...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pstoedit
Version: 16
Hardware: Unspecified
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Popelka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-15 16:39 UTC by Quintin Hill
Modified: 2012-04-26 03:30 UTC (History)
4 users (show)

Fixed In Version: pstoedit-3.60-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-26 03:30:03 UTC


Attachments (Terms of Use)

Description Quintin Hill 2010-11-15 16:39:44 UTC
Description of problem:
Runtime error generated:

Inconsistency detected by ld.so: dl-close.c: 743: _dl_close: Assertion `map->l_init_called' failed!

Version-Release number of selected component (if applicable):
pstoedit-3.45-9.fc12  (Apparently not rebuilt since F12.)

How reproducible:


Steps to Reproduce:
1. $ yum install pstoedit
2. $ pstoedit
  
Actual results:

pstoedit: version 3.45 / DLL interface 108 (build Jul 28 2009 - release build - g++ 4.4.1 20090725 (Red Hat 4.4.1-3)) : Copyright (C) 1993 - 2007 Wolfgang Glunz
No output format specified (-f option) and format could not be deduced from suffix of output file since no output file name was given
Usage: "pstoedit -f format inputfile outputfile" or run "pstoedit -help" to get a complete list available options.
Inconsistency detected by ld.so: dl-close.c: 743: _dl_close: Assertion `map->l_init_called' failed!

Expected results:
(This is the output from a Fedora 12 installation.)

pstoedit: version 3.45 / DLL interface 108 (build Jul 28 2009 - release build - g++ 4.4.1 20090725 (Red Hat 4.4.1-3)) : Copyright (C) 1993 - 2007 Wolfgang Glunz
No output format specified (-f option) and format could not be deduced from suffix of output file since no output file name was given
Usage: "pstoedit -f format inputfile outputfile" or run "pstoedit -help" to get a complete list available options.


Additional info:

Comment 1 Jiri Popelka 2010-12-16 18:24:23 UTC
I didn't discover what's the source of this warning, but it seems that it doesn't limit the functionality of pstoedit.
Rebuilding pstoedit doesn't help.

Comment 2 Jiri Popelka 2011-08-29 15:54:07 UTC
I'm not seeing this problem with pstoedit-3.45-10.fc15.x86_64 anymore. Closing.

Comment 3 Matt Hirsch 2011-11-17 08:10:04 UTC
I am now getting this bug again on Fedora 16. I did not see this problem in 15, but after upgrading to 16 I see the problem again. Note that pstoedit has not been rebuilt for Fedora 16. So I still get pstoedit-3.45-10.fc15.x86_64 installed when I do a yum install pstoedit.

I attempted a naive rebuild with the following

yumdownloader --source pstoedit
yum-builddep pstoedit
rpmbuild -bb pstoedit.spec

The new "f16" package still has the same problem. Please reopen this bug.

Comment 4 Jiri Popelka 2011-11-18 10:59:12 UTC
(In reply to comment #3)
> The new "f16" package still has the same problem. Please reopen this bug.
Confirmed.

I've updated pstoedit in rawhide to 3.60 and that version seems to be ok.
https://koji.fedoraproject.org/koji/buildinfo?buildID=260992

Comment 5 David Jansen 2012-01-23 15:51:05 UTC
Will we ever see an update for the version in Fedora 16?

Comment 6 Fedora Update System 2012-01-23 16:17:46 UTC
pstoedit-3.60-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/pstoedit-3.60-1.fc16

Comment 7 Fedora Update System 2012-01-23 21:58:10 UTC
Package pstoedit-3.60-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pstoedit-3.60-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0829/pstoedit-3.60-1.fc16
then log in and leave karma (feedback).

Comment 8 Gert Klopman 2012-02-10 14:16:07 UTC
For me that solved the problem

Comment 9 Fedora Update System 2012-04-26 03:30:03 UTC
pstoedit-3.60-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.